summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ccd7d0a05639..f7587893978b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
# Generated by mksrcinfo v8
-# Sun Sep 10 18:08:13 UTC 2017
+# Thu Sep 14 16:06:46 UTC 2017
pkgbase = cottage
pkgdesc = Use howm commands, operators and set configuration values through a UNIX socket.
pkgver = 0.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/HarveyHunt/cottage
arch = i686
arch = x86_64
license = GPL
source = cottage-0.3.tar.gz::https://github.com/HarveyHunt/cottage/archive/v0.3.tar.gz
+ source = fix-ldflags.patch::https://patch-diff.githubusercontent.com/raw/HarveyHunt/cottage/pull/11.patch
sha256sums = edf196357f7ff86ff615407926e3aa96007f65c5128990b3fa51bd08677a946b
+ sha256sums = b8f849db21d230c6fd800c9979e16620970110da2f69b1a646c07399b4481d26
pkgname = cottage
diff --git a/PKGBUILD b/PKGBUILD
index 7a62992ade90..383b95bfdf8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,29 @@
# Maintainer: Alad Wenter <alad@mailbox.org>
pkgname=cottage
pkgver=0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Use howm commands, operators and set configuration values through a UNIX socket."
arch=('i686' 'x86_64')
url="https://github.com/HarveyHunt/cottage"
license=('GPL')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/HarveyHunt/cottage/archive/v$pkgver.tar.gz")
-sha256sums=('edf196357f7ff86ff615407926e3aa96007f65c5128990b3fa51bd08677a946b')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/HarveyHunt/cottage/archive/v$pkgver.tar.gz"
+ 'fix-ldflags.patch::https://patch-diff.githubusercontent.com/raw/HarveyHunt/cottage/pull/11.patch')
+sha256sums=('edf196357f7ff86ff615407926e3aa96007f65c5128990b3fa51bd08677a946b'
+ 'b8f849db21d230c6fd800c9979e16620970110da2f69b1a646c07399b4481d26')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 < "$srcdir"/fix-ldflags.patch
+}
build() {
- cd "$pkgname-$pkgver"
- make
+ cd "$pkgname-$pkgver"
+ make
}
package() {
- cd "$pkgname-$pkgver"
- install -Dm755 cottage "$pkgdir"/usr/bin/cottage
+ cd "$pkgname-$pkgver"
+ install -Dm755 cottage "$pkgdir"/usr/bin/cottage
}
# vim:set ts=2 sw=2 et: