summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 9 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 780431e60660..c197b7831556 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,13 @@
pkgbase = cpcli-git
pkgdesc = Check crypto prices in your terminal
- pkgver = 1.0.0
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/AshtonGrimes/cpcli
- arch = x86_64
- arch = i686
- arch = aarch64
- arch = armv7
+ arch = any
license = GPL-3.0-or-later
makedepends = git
- makedepends = rust
- depends = glibc
- depends = gcc-libs
- depends = openssl
+ depends = guile
+ depends = guile-json
source = git+https://github.com/AshtonGrimes/cpcli
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d4ef554719c8..2e73576a79e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,20 @@
# Maintainer: Ashton Grimes <amgrimes2002@gmail.com>
pkgname=cpcli-git
-pkgver=1.0.0
+pkgver=1.1.0
pkgrel=1
pkgdesc="Check crypto prices in your terminal"
-arch=(x86_64 i686 aarch64 armv7)
+arch=(any)
url="https://github.com/AshtonGrimes/cpcli"
license=(GPL-3.0-or-later)
-depends=(glibc gcc-libs openssl)
-makedepends=(git rust)
+depends=(guile guile-json)
+makedepends=(git)
source=("git+https://github.com/AshtonGrimes/cpcli")
sha256sums=(SKIP)
-pkgver() {
- cd cpcli
- grep '^version' Cargo.toml | head -n1 | sed -E 's/.*"(.*)"$/\1/'
-}
-
-build() {
- cd cpcli
- CFLAGS="-O2 -pipe" CXXFLAGS="-O2 -pipe" cargo build --locked --release
-}
-
package() {
cd cpcli
- install -Dm755 target/release/cpcli -t "$pkgdir/usr/bin"
+ install -Dm755 cpcli.scm -T "$pkgdir/usr/bin/cpcli"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}