summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD43
2 files changed, 27 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8918a9d17f65..ad850425f15a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = cpeditor-git
pkgdesc = The editor for competitive programming
- pkgver = 7.0.1.r2.g0613a9c2
+ pkgver = 7.0.1.r3.g21813202
pkgrel = 1
url = https://github.com/cpeditor/cpeditor
arch = x86_64
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = cmake
makedepends = git
makedepends = ninja
makedepends = python3
makedepends = qt5-tools
depends = qt5-base
+ depends = qt5-svg
depends = syntax-highlighting5
depends = hicolor-icon-theme
optdepends = cf-tool: submit to Codeforces
diff --git a/PKGBUILD b/PKGBUILD
index c6d1b7c96991..e4d04b97b9ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,24 @@
pkgname=cpeditor-git
_pkgname=cpeditor
-pkgver=7.0.1.r2.g0613a9c2
+pkgver=7.0.1.r3.g21813202
pkgrel=1
pkgdesc='The editor for competitive programming'
arch=('x86_64')
url='https://github.com/cpeditor/cpeditor'
-license=('GPL3')
-depends=('qt5-base' 'syntax-highlighting5' 'hicolor-icon-theme')
+license=('GPL-3.0-or-later')
+depends=(
+ 'qt5-base'
+ 'qt5-svg'
+ 'syntax-highlighting5'
+ 'hicolor-icon-theme'
+)
makedepends=(
- "cmake"
- "git"
- "ninja"
- "python3"
- "qt5-tools"
+ 'cmake'
+ 'git'
+ 'ninja'
+ 'python3'
+ 'qt5-tools'
)
optdepends=(
'cf-tool: submit to Codeforces'
@@ -25,14 +30,16 @@ optdepends=(
'wakatime: track coding stats'
)
provides=('cpeditor')
-conflicts=("cpeditor")
+conflicts=('cpeditor')
-source=('git+https://github.com/cpeditor/cpeditor.git'
+source=(
+ 'git+https://github.com/cpeditor/cpeditor.git'
'git+https://github.com/cpeditor/QtFindReplaceDialog.git'
'git+https://github.com/cpeditor/lsp-cpp.git'
'git+https://github.com/itay-grudev/singleapplication.git'
'git+https://github.com/MikeMirzayanov/testlib.git'
- 'git+https://github.com/cpeditor/qhttp.git')
+ 'git+https://github.com/cpeditor/qhttp.git'
+)
md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
@@ -43,15 +50,13 @@ pkgver() {
prepare() {
cd "$_pkgname"
- git submodule init
-
- git config submodule.third_party/QtFindReplaceDialog.url "$srcdir/QtFindReplaceDialog"
- git config submodule.third_party/lsp-cpp.url "$srcdir/lsp-cpp"
- git config submodule.third_party/singleapplication.url "$srcdir/singleapplication"
- git config submodule.third_party/testlib.url "$srcdir/testlib"
- git config submodule.third_party/qhttp.url "$srcdir/qhttp"
- git -c protocol.file.allow=always submodule update
+ for _source in "${source[@]:1}"; do
+ _name=$(basename "$_source" .git)
+ _path="third_party/$_name"
+ git config submodule."$_path".url "$srcdir/$_name"
+ git -c protocol.file.allow=always submodule update --init -- "$_path"
+ done
}
build() {