summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 216774fec588..9c156c1863af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cppcheck-git
pkgdesc = Tool for static C/C++ code analysis
- pkgver = 2.7.r1629.647432580
+ pkgver = 2.7.r1730.58dd92dd1
pkgrel = 1
epoch = 1
url = https://cppcheck.sourceforge.io/
@@ -18,13 +18,14 @@ pkgbase = cppcheck-git
depends = pcre
depends = python
depends = tinyxml2
+ optdepends = qt5-tools: cppcheck-gui
+ optdepends = python-pygments: cppcheck-htmlreport
+ optdepends = clang: cppcheck-gui integration
provides = cppcheck
conflicts = cppcheck
source = git+https://github.com/danmar/cppcheck.git
- source = 0001-Add-missing-rebinding-trait-to-TaggedAllocator.patch
source = translations-location.patch
b2sums = SKIP
- b2sums = 7c7e259c20b5c6ec9cfd5831fb0bd912aa2fa5b5f6c5afc18a6741e952138eacc9a2702f1b6f009beb75ddb724af29e3c0f4905f927cc091e3caf02566ca582a
b2sums = 8156920eacc630cb5eceb2387937b747c84c6325bef906717cfbad68c122bdd27965da1e8070a560a0bed3a7b7c59ff5f0e116bb1d035c4c42f430c927a75b1f
pkgname = cppcheck-git
diff --git a/PKGBUILD b/PKGBUILD
index c5029c5f9518..7a6161af10c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=cppcheck
pkgname="$_pkgname-git"
-pkgver=2.7.r1629.647432580
+pkgver=2.7.r1730.58dd92dd1
pkgrel=1
epoch=1
pkgdesc='Tool for static C/C++ code analysis'
@@ -16,20 +16,17 @@ provides=("$_pkgname")
conflicts=("$_pkgname")
depends=(pcre python tinyxml2)
makedepends=(clang cmake docbook-xsl git pandoc python-pygments qt5-base qt5-tools)
-optdeps=('qt5-tools: cppcheck-gui'
- 'python-pygments: cppcheck-htmlreport'
- 'clang: cppcheck-gui integration')
+optdepends=('qt5-tools: cppcheck-gui'
+ 'python-pygments: cppcheck-htmlreport'
+ 'clang: cppcheck-gui integration')
source=("git+https://github.com/danmar/$_pkgname.git"
- 0001-Add-missing-rebinding-trait-to-TaggedAllocator.patch
translations-location.patch)
b2sums=('SKIP'
- '7c7e259c20b5c6ec9cfd5831fb0bd912aa2fa5b5f6c5afc18a6741e952138eacc9a2702f1b6f009beb75ddb724af29e3c0f4905f927cc091e3caf02566ca582a'
'8156920eacc630cb5eceb2387937b747c84c6325bef906717cfbad68c122bdd27965da1e8070a560a0bed3a7b7c59ff5f0e116bb1d035c4c42f430c927a75b1f')
prepare() {
cd $_pkgname
patch -Np1 -i ../translations-location.patch
- patch -Np1 -i ../0001-Add-missing-rebinding-trait-to-TaggedAllocator.patch
}
pkgver() {