summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
3 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4920467c053..f8a675d20772 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,9 +8,7 @@ pkgbase = cppyy-cling
license = LGPL2.1
license = UoI-NCSA
depends = python
- depends = python-wheel
- depends = python-pip
- source = https://files.pythonhosted.org/packages/32/1e/b1c53769953c3425bddd16c770399374eb9897333a3fba49f699d17e9526/cppyy_cling-6.28.0-py2.py3-none-manylinux2014_x86_64.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/c/cppyy-cling/cppyy_cling-6.28.0-py2.py3-none-manylinux2014_x86_64.whl
sha256sums = 6db5ea865207387f52c6beda4f65298137309ffebf9d20fa2281e5fc8dbb3323
pkgname = cppyy-cling
diff --git a/.gitignore b/.gitignore
index 4ac1ce2af02c..5c0867d82df8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ instructions.txt
/pkg/
/src/
*.tar.*
+*.whl
diff --git a/PKGBUILD b/PKGBUILD
index 210dae6cb9d4..b26b726483fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,17 @@ pkgdesc="Cling-based Python-C++ bindings (cling backend)"
arch=('x86_64')
url="https://cppyy.readthedocs.io/en/latest/index.html"
license=('LGPLv2+' 'LGPL2.1' 'UoI-NCSA')
-depends=('python' 'python-wheel' 'python-pip')
-source=("https://files.pythonhosted.org/packages/32/1e/b1c53769953c3425bddd16c770399374eb9897333a3fba49f699d17e9526/cppyy_cling-${pkgver}-py2.py3-none-manylinux2014_x86_64.whl")
+depends=('python')
+source=("https://files.pythonhosted.org/packages/py2.py3/${pkgname::1}/$pkgname/${pkgname//-/_}-$pkgver-py2.py3-none-manylinux2014_x86_64.whl")
sha256sums=('6db5ea865207387f52c6beda4f65298137309ffebf9d20fa2281e5fc8dbb3323')
+# Install from wheel, since:
+#
+# Wheels are available for the major platforms,
+# but if you have to build from source, building
+# of LLVM will take a long time.
+#
+# as stated in cppyy's website.
package() {
- cd $srcdir
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
- python -O -m compileall "${pkgdir}$(python -c "import site; print(site.getsitepackages()[0])")/cppyy_backend"
+ python -m installer --destdir="$pkgdir" "${pkgname//-/_}-$pkgver-py2.py3-none-manylinux2014_x86_64.whl"
}
-