summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD6
-rw-r--r--cpu-x-git.install11
4 files changed, 19 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a02a39b8ca52..223b4d14ee56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
# Generated by mksrcinfo v8
-# Wed Dec 30 15:10:14 UTC 2015
+# Tue Mar 8 06:53:08 UTC 2016
pkgbase = cpu-x-git
pkgdesc = A Free software that gathers information on CPU, motherboard and more (like CPU-Z)
- pkgver = 2.91.0.r0.16a5f27
+ pkgver = 2.91.0.r83.g7d45def
pkgrel = 1
url = https://github.com/X0rg/CPU-X
+ install = cpu-x-git.install
arch = i686
arch = x86_64
license = GPL3
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..db0cfbad7450 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!.SRCINFO
!PKGBUILD
+!cpu-x-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 1dad8049ab61..a9d15f52e9c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_realname=CPU-X
pkgname=cpu-x-git
-pkgver=2.91.0.r0.16a5f27
+pkgver=2.91.0.r83.g7d45def
pkgrel=1
pkgdesc="A Free software that gathers information on CPU, motherboard and more (like CPU-Z)"
arch=('i686' 'x86_64')
@@ -13,12 +13,14 @@ makedepends=('cmake' 'nasm')
provides=('cpu-x')
conflicts=('cpu-x')
options=('debug')
+install=$pkgname.install
source=("git+https://github.com/X0rg/CPU-X.git")
md5sums=('SKIP')
pkgver() {
cd "$_realname"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ v=$(grep "VERSION" CMakeLists.txt | sed -n 2p | awk '{ print $2 }')
+ git describe --long --tags | sed -e "s/^v//;s/2.2.2/$v/;s/\([^-]*-g\)/r\1/;s/-/./g"
}
prepare() {
diff --git a/cpu-x-git.install b/cpu-x-git.install
new file mode 100644
index 000000000000..81f2ba659316
--- /dev/null
+++ b/cpu-x-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}