summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--CrashPlanDesktop-run.conf.patch8
-rw-r--r--PKGBUILD85
-rw-r--r--crashplan-pro-e.install11
-rw-r--r--crashplan-pro-e.service17
5 files changed, 146 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27769df99185
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by makepkg 4.2.0
+# Tue Jan 6 15:19:22 UTC 2015
+pkgbase = crashplan-pro-e
+ pkgdesc = An enterprise online/offsite backup solution
+ pkgver = 3.6.4
+ pkgrel = 1
+ url = http://www.crashplan.com/enterprise
+ install = crashplan-pro-e.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = grep
+ makedepends = cpio
+ makedepends = gzip
+ depends = java-runtime
+ optdepends = swt: needed by some to open the GUI
+ source = http://download.crashplan.com/installs/linux/install/CrashPlanPROe/CrashPlanPROe_3.6.4_Linux.tgz
+ source = crashplan-pro-e.service
+ source = CrashPlanDesktop-run.conf.patch
+ sha256sums = eac1742a554e4410f4877b506effbd577a491ccbc70c173915d9293077329ee3
+ sha256sums = 1ca45875025fcf8a4ec6e6f9588807453f65da38b6a0e06c7bb94feb66edda9c
+ sha256sums = 1ec0c53ab7bd942e24b9691e178afa397755742a04718ccb88e2bd8af8a009ac
+
+pkgname = crashplan-pro-e
+
diff --git a/CrashPlanDesktop-run.conf.patch b/CrashPlanDesktop-run.conf.patch
new file mode 100644
index 000000000000..4523d8e7ed64
--- /dev/null
+++ b/CrashPlanDesktop-run.conf.patch
@@ -0,0 +1,8 @@
+diff -aur CrashPlanPROe-install.orig/scripts/run.conf CrashPlanPROe-install/scripts/run.conf
+--- CrashPlanPROe-install.orig/scripts/run.conf 2014-02-19 18:17:19.000000000 -0500
++++ CrashPlanPROe-install/scripts/run.conf 2014-09-19 14:25:20.901002692 -0400
+@@ -1,2 +1,2 @@
+ SRV_JAVA_OPTS="-Dfile.encoding=UTF-8 -Dapp=CrashPlanService -DappBaseName=CrashPlan -Xms20m -Xmx1024m -Djava.net.preferIPv4Stack=true -Dsun.net.inetaddr.ttl=300 -Dnetworkaddress.cache.ttl=300 -Dsun.net.inetaddr.negative.ttl=0 -Dnetworkaddress.cache.negative.ttl=0 -Dc42.native.md5.enabled=false"
+-GUI_JAVA_OPTS="-Dfile.encoding=UTF-8 -Dapp=CrashPlanDesktop -DappBaseName=CrashPlan -Xms20m -Xmx512m -Djava.net.preferIPv4Stack=true -Dsun.net.inetaddr.ttl=300 -Dnetworkaddress.cache.ttl=300 -Dsun.net.inetaddr.negative.ttl=0 -Dnetworkaddress.cache.negative.ttl=0 -Dc42.native.md5.enabled=false"
+\ No newline at end of file
++GUI_JAVA_OPTS="-Dfile.encoding=UTF-8 -Dapp=CrashPlanDesktop -DappBaseName=CrashPlan -Xms20m -Xmx512m -Djava.net.preferIPv4Stack=true -Dsun.net.inetaddr.ttl=300 -Dnetworkaddress.cache.ttl=300 -Dsun.net.inetaddr.negative.ttl=0 -Dnetworkaddress.cache.negative.ttl=0 -Dc42.native.md5.enabled=false -Dorg.eclipse.swt.browser.DefaultType=mozilla"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4f4633a1791
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,85 @@
+# Maintainer: Anthony DeStefano <adx [at] fastmail [dot] fm>
+# Contributor: Maarten de Boer <info [at] maartendeboer [dot] net>
+# Contributor: Egon Geerardyn <egon [dot] geerardyn [at] gmail [dot] com>
+# Contributor: Bill Durr <billyburly [at] gmail [dot] com>
+pkgname=crashplan-pro-e
+pkgver=3.6.4
+pkgrel=1
+pkgdesc="An enterprise online/offsite backup solution"
+url="http://www.crashplan.com/enterprise"
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('java-runtime')
+makedepends=('grep' 'cpio' 'gzip')
+optdepends=('swt: needed by some to open the GUI')
+backup=()
+install=crashplan-pro-e.install
+source=(http://download.crashplan.com/installs/linux/install/CrashPlanPROe/CrashPlanPROe_${pkgver}_Linux.tgz
+ crashplan-pro-e.service
+ CrashPlanDesktop-run.conf.patch)
+sha256sums=('eac1742a554e4410f4877b506effbd577a491ccbc70c173915d9293077329ee3'
+ '1ca45875025fcf8a4ec6e6f9588807453f65da38b6a0e06c7bb94feb66edda9c'
+ '1ec0c53ab7bd942e24b9691e178afa397755742a04718ccb88e2bd8af8a009ac')
+
+build() {
+ cd $srcdir/CrashPlanPROe-install
+
+ echo ""
+ echo "You must review and agree to the EULA before using Crashplan PROe."
+ echo "You can do so at:"
+ echo " - http://support.crashplan.com/doku.php/eula"
+ echo " - /usr/share/licenses/${pkgname}/LICENSE"
+ echo ""
+
+ echo "" > install.vars
+ echo "JAVACOMMON=`which java`" >> install.vars
+ echo "#APP_BASENAME=CrashPlan" >> install.vars
+ echo "TARGETDIR=/opt/$pkgname" >> install.vars
+ echo "BINSDIR=" >> install.vars
+ echo "MANIFESTDIR=/opt/$pkgname/manifest" >> install.vars
+ echo "INITDIR=" >> install.vars
+ echo "RUNLVLDIR=" >> install.vars
+ NOW=`date +%Y%m%d`
+ echo "INSTALLDATE=$NOW" >> install.vars
+
+ sed -imod "s|Exec=.*|Exec=/opt/$pkgname/bin/CrashPlanDesktop|" scripts/CrashPlan.desktop
+ sed -imod "s|Icon=.*|Icon=/opt/$pkgname/skin/icon_app_64x64.png|" scripts/CrashPlan.desktop
+ sed -imod "s|Categories=.*|Categories=System;|" scripts/CrashPlan.desktop
+
+ patch -p1 -i $srcdir/CrashPlanDesktop-run.conf.patch
+}
+
+package() {
+ mkdir -p $pkgdir/opt/$pkgname
+ cd $pkgdir/opt/$pkgname
+
+ cat $srcdir/CrashPlanPROe-install/CrashPlanPROe_$pkgver.cpi | gzip -d -c - | cpio -i --no-preserve-owner
+ chmod 777 $pkgdir/opt/$pkgname/log
+ sed -i "s|<manifestPath>manifest</manifestPath>|<manifestPath>/opt/$pkgname/manifest</manifestPath>|g" $pkgdir/opt/$pkgname/conf/default.service.xml
+
+ mkdir -p $pkgdir/usr/bin
+ ln -s "/opt/$pkgname/bin/CrashPlanDesktop" $pkgdir/usr/bin/CrashPlanDesktop
+
+ # Fix for 32 bit: 64 bit libs cannot be stripped from symbols
+ # so we just remove those libs
+ if [ "$CARCH" = "i686" ]; then
+ rm $pkgdir/opt/$pkgname/*64.so
+ fi
+
+ # Fix for encoding troubles (CrashPlan ticket 178827)
+ # Make sure the daemon is running using the same localization as
+ # the (installing) user
+ echo "" >> $srcdir/CrashPlanPROe-install/scripts/run.conf
+ echo "export LC_ALL=$LANG" >> $srcdir/CrashPlanPROe-install/scripts/run.conf
+
+ install -D -m 644 $srcdir/CrashPlanPROe-install/install.vars $pkgdir/opt/$pkgname/install.vars
+ install -D -m 644 $srcdir/CrashPlanPROe-install/EULA.txt $pkgdir/opt/$pkgname/EULA.txt
+ install -D -m 644 $srcdir/CrashPlanPROe-install/EULA.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m 755 $srcdir/CrashPlanPROe-install/scripts/CrashPlanDesktop $pkgdir/opt/$pkgname/bin/CrashPlanDesktop
+ install -D -m 644 $srcdir/CrashPlanPROe-install/scripts/run.conf $pkgdir/opt/$pkgname/bin/run.conf
+ install -D -m 755 $srcdir/CrashPlanPROe-install/scripts/CrashPlanEngine $pkgdir/opt/$pkgname/bin/CrashPlanEngine
+ install -D -m 755 $srcdir/CrashPlanPROe-install/scripts/CrashPlan.desktop $pkgdir/usr/share/applications/crashplan.desktop
+
+ # systemd unit
+ install -D -m 644 $srcdir/crashplan-pro-e.service $pkgdir/usr/lib/systemd/system/crashplan-pro-e.service
+}
diff --git a/crashplan-pro-e.install b/crashplan-pro-e.install
new file mode 100644
index 000000000000..cd6480a50df1
--- /dev/null
+++ b/crashplan-pro-e.install
@@ -0,0 +1,11 @@
+post_install () {
+ INOTIFY_WATCHES=`cat /proc/sys/fs/inotify/max_user_watches`
+ if [[ $INOTIFY_WATCHES -le 8192 ]]; then
+ echo ""
+ echo "Your system is currently configured to watch $INOTIFY_WATCHES files in real time."
+ echo "CrashPlan recommends using a larger value; see the CrashPlan support site for details."
+ echo "e.g. add the following line to /etc/sysctl.d/99-sysctl.conf "
+ echo " fs.inotify.max_user_watches=1048576"
+ echo ""
+ fi
+}
diff --git a/crashplan-pro-e.service b/crashplan-pro-e.service
new file mode 100644
index 000000000000..4ca8ae72098b
--- /dev/null
+++ b/crashplan-pro-e.service
@@ -0,0 +1,17 @@
+[Unit]
+Description=CrashPlanPROe Backup Engine
+After=network.target
+
+[Service]
+
+Type=forking
+PIDFile=/opt/crashplan-pro-e/CrashPlanEngine.pid
+EnvironmentFile=/opt/crashplan-pro-e/bin/run.conf
+
+WorkingDirectory=/opt/crashplan-pro-e
+
+ExecStart=/opt/crashplan-pro-e/bin/CrashPlanEngine start
+ExecStop=/opt/crashplan-pro-e/bin/CrashPlanEngine stop
+
+[Install]
+WantedBy=multi-user.target