summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--020-cs-libguarded-catch2-v3-fix.patch99
-rw-r--r--PKGBUILD9
3 files changed, 108 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5106a02b51f..a5aa9fd399bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cs-libguarded
pkgdesc = Header only library for multithreaded programming
pkgver = 1.4.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.copperspice.com/
arch = any
license = BSD
@@ -9,7 +9,9 @@ pkgbase = cs-libguarded
makedepends = catch2
source = https://github.com/copperspice/cs_libguarded/archive/libguarded-1.4.1/cs-libguarded-1.4.1.tar.gz
source = 010-cs-libguarded-gcc13-fix.patch
+ source = 020-cs-libguarded-catch2-v3-fix.patch
sha256sums = e91235d4f5e5edb4a479fccfcd1bdc2a411dd3e3344f5c973ce5870edbab13b0
sha256sums = ddf09d574edc104deeffe884b3e420cef120f72eae8d447109a5f9192d589a13
+ sha256sums = 69088e9c0a57834695c7ec27fda5c3df8900621225a5551c37e1b5ad03e6f5e1
pkgname = cs-libguarded
diff --git a/020-cs-libguarded-catch2-v3-fix.patch b/020-cs-libguarded-catch2-v3-fix.patch
new file mode 100644
index 000000000000..a0c67da8aa7b
--- /dev/null
+++ b/020-cs-libguarded-catch2-v3-fix.patch
@@ -0,0 +1,99 @@
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -10,7 +10,7 @@ add_executable(CsLibGuardedTest "")
+ target_link_libraries(CsLibGuardedTest
+ PUBLIC
+ CsLibGuarded
+- Catch2::Catch2
++ Catch2::Catch2WithMain
+ Threads::Threads
+ )
+
+--- a/test/test_cow.cpp
++++ b/test/test_cow.cpp
+@@ -19,7 +19,7 @@
+
+ #include <thread>
+
+-#include <catch2/catch.hpp>
++#include <catch2/catch_all.hpp>
+
+ using namespace libguarded;
+
+--- a/test/test_deferred.cpp
++++ b/test/test_deferred.cpp
+@@ -21,7 +21,7 @@
+ #include <shared_mutex>
+ using shared_mutex = std::shared_timed_mutex;
+
+-#include <catch2/catch.hpp>
++#include <catch2/catch_all.hpp>
+
+ using namespace libguarded;
+
+--- a/test/test_lock.cpp
++++ b/test/test_lock.cpp
+@@ -22,7 +22,7 @@
+ #include <mutex>
+
+ #define CATCH_CONFIG_MAIN
+-#include <catch2/catch.hpp>
++#include <catch2/catch_all.hpp>
+
+ #include <atomic>
+ #include <thread>
+--- a/test/test_lr.cpp
++++ b/test/test_lr.cpp
+@@ -19,7 +19,7 @@
+
+ #include <thread>
+
+-#include <catch2/catch.hpp>
++#include <catch2/catch_all.hpp>
+
+ using namespace libguarded;
+
+--- a/test/test_ordered.cpp
++++ b/test/test_ordered.cpp
+@@ -23,7 +23,7 @@
+ #include <shared_mutex>
+ using shared_mutex = std::shared_timed_mutex;
+
+-#include <catch2/catch.hpp>
++#include <catch2/catch_all.hpp>
+
+ using namespace libguarded;
+
+--- a/test/test_rcu.cpp
++++ b/test/test_rcu.cpp
+@@ -21,7 +21,7 @@
+ #include <thread>
+ #include <iostream>
+
+-#include <catch2/catch.hpp>
++#include <catch2/catch_all.hpp>
+
+ using namespace libguarded;
+
+--- a/test/test_read_lock.cpp
++++ b/test/test_read_lock.cpp
+@@ -20,7 +20,7 @@
+ #include <cs_shared_guarded.h>
+ #include <mutex>
+
+-#include <catch2/catch.hpp>
++#include <catch2/catch_all.hpp>
+
+ #include <atomic>
+ #include <thread>
+--- a/test/test_shared.cpp
++++ b/test/test_shared.cpp
+@@ -24,7 +24,7 @@
+ using shared_mutex = std::shared_timed_mutex;
+ namespace chrono = std::chrono;
+
+-#include <catch2/catch.hpp>
++#include <catch2/catch_all.hpp>
+
+ using namespace libguarded;
+
diff --git a/PKGBUILD b/PKGBUILD
index 75073c68c250..4dcc3f64c39a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,22 @@
pkgname=cs-libguarded
pkgver=1.4.1
-pkgrel=1
+pkgrel=2
pkgdesc='Header only library for multithreaded programming'
arch=('any')
url='https://www.copperspice.com/'
license=('BSD')
makedepends=('cmake' 'catch2')
source=("https://github.com/copperspice/cs_libguarded/archive/libguarded-${pkgver}/${pkgname}-${pkgver}.tar.gz"
- '010-cs-libguarded-gcc13-fix.patch')
+ '010-cs-libguarded-gcc13-fix.patch'
+ '020-cs-libguarded-catch2-v3-fix.patch')
sha256sums=('e91235d4f5e5edb4a479fccfcd1bdc2a411dd3e3344f5c973ce5870edbab13b0'
- 'ddf09d574edc104deeffe884b3e420cef120f72eae8d447109a5f9192d589a13')
+ 'ddf09d574edc104deeffe884b3e420cef120f72eae8d447109a5f9192d589a13'
+ '69088e9c0a57834695c7ec27fda5c3df8900621225a5551c37e1b5ad03e6f5e1')
prepare() {
patch -d "cs_libguarded-libguarded-${pkgver}" -Np1 -i "${srcdir}/010-cs-libguarded-gcc13-fix.patch"
+ patch -d "cs_libguarded-libguarded-${pkgver}" -Np1 -i "${srcdir}/020-cs-libguarded-catch2-v3-fix.patch"
}
build() {