summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..342dc04276e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cstat
+ pkgdesc = A tool to gather real-time statistics from Cube and Cube 2 game servers
+ pkgver = 0.9.9
+ pkgrel = 1
+ url = http://cstat.y7.ath.cx/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = http://downloads.sourceforge.net/project/cubestat/cstat-0.9.9-src.tar.gz
+ md5sums = b0aaea5be673f2a57046428e6e7f861b
+
+pkgname = cstat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68262a4d0d79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
+
+pkgname=cstat
+pkgver=0.9.9
+pkgrel=1
+pkgdesc="A tool to gather real-time statistics from Cube and Cube 2 game servers"
+arch=('i686' 'x86_64')
+url="http://cstat.y7.ath.cx/"
+license=('GPL')
+depends=('glibc')
+source=(http://downloads.sourceforge.net/project/cubestat/$pkgname-$pkgver-src.tar.gz)
+md5sums=('b0aaea5be673f2a57046428e6e7f861b')
+
+build() {
+ cd $pkgname-$pkgver-src/src
+
+ export CFLAGS+=" -I. -DHAVE_CONFIG_H"
+
+ ./configure --prefix=/usr
+ make || return 1
+ install -Dm755 cstat "$pkgdir"/usr/bin/cstat
+}
+
+# vim:set ts=2 sw=2 et: