summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 801e74fa22a9..7aeaa078f4a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cubic-bot-telegram-git
pkgdesc = A stupid and annoying chatbot for your group chats
- pkgver = 1.0.r36.g451e627
+ pkgver = 1.0.r42.g9bb3bd2
pkgrel = 1
url = https://github.com/database64128/CubicBot
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index f58d5a32659f..b1c95c5d5502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: database64128 <free122448@hotmail.com>
+
pkgname=cubic-bot-telegram-git
-pkgver=1.0.r36.g451e627
+pkgver=1.0.r42.g9bb3bd2
pkgrel=1
pkgdesc="A stupid and annoying chatbot for your group chats"
arch=(x86_64)
@@ -14,12 +15,12 @@ source=("$pkgname::git+$url.git")
b2sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
+ cd $pkgname
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/$pkgname"
+ cd $pkgname
dotnet publish CubicBot.Telegram -c Release \
-p:DefineConstants=PACKAGED \
-p:PublishReadyToRun=true \
@@ -34,7 +35,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname"
+ cd $pkgname
install -Dm755 CubicBot.Telegram/bin/Release/net5.0/linux-x64/publish/cubic-bot-telegram $pkgdir/usr/bin/cubic-bot-telegram
install -Dm644 systemd/user/cubic-bot-telegram.service $pkgdir/usr/lib/systemd/user/cubic-bot-telegram.service
}