summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD45
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a417df41fea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cufflinks-git
+ pkgdesc = Cufflinks assembles transcripts, estimates their abundances, and tests for differential expression and regulation in RNA-Seq samples..
+ pkgver = v2.2.1.r83.gb4fa050
+ pkgrel = 1
+ url = http://cole-trapnell-lab.github.io/projects/cufflinks/
+ arch = x86_64
+ license = Artistic
+ depends = boost
+ depends = eigen3
+ depends = python2
+ depends = samtools
+ depends = perl
+ source = git+https://github.com/cole-trapnell-lab/cufflinks.git
+ md5sums = SKIP
+
+pkgname = cufflinks-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4a758110fea
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/src
+/pkg
+*.tar.gz
+*.tar.xz
+*.pkg.tar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53a4c8af1748
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Grey Christoforo <first name @ last name .net>
+
+pkgname=cufflinks-git
+pkgver=v2.2.1.r83.gb4fa050
+pkgrel=1
+pkgdesc="Cufflinks assembles transcripts, estimates their abundances, and tests for differential expression and regulation in RNA-Seq samples.."
+arch=("x86_64")
+url="http://cole-trapnell-lab.github.io/projects/cufflinks/"
+license=('Artistic')
+depends=('boost' 'eigen3' 'python2' 'samtools' 'perl')
+source=('git+https://github.com/cole-trapnell-lab/cufflinks.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd cufflinks
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd cufflinks
+
+ sed -i 's,hash\[pos\]\.hash,(hash[pos].hash),g' src/GHash.hh
+
+
+
+ ./autogen.sh
+ # cufflinks uses python2 but archlinux uses python3 as default python
+ perl -i -pne '$_ =~ s/python/python2/ if $_ =~ /^#!\/usr/' src/cuffmerge
+
+ export EIGEN_CPPFLAGS="-I/usr/include/eigen3"
+ export LDFLAGS="-L/usr/lib -lboost_system"
+ ./configure --prefix=/usr
+}
+
+build() {
+ cd cufflinks
+ export EIGEN_CPPFLAGS="-I/usr/include/eigen3"
+ export LDFLAGS="-L/usr/lib -lboost_system"
+ make
+}
+
+package(){
+ cd cufflinks
+ make DESTDIR="$pkgdir/" install
+}