summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
-rw-r--r--cups-ocr.install16
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d30330a80f88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cups-ocr
+ pkgdesc = Print directly to a tiff file which feeds an OCR engine which will output a text file. Modelled after cups-pdf.
+ pkgver = 0.1.2
+ pkgrel = 4
+ url = http://github.com/t0nedef/cups-ocr/
+ install = cups-ocr.install
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL2
+ depends = cups
+ depends = imagemagick
+ depends = tesseract
+ backup = etc/cups/cups-ocr.conf
+ source = https://github.com/t0nedef/cups-ocr/archive/0.1.2.tar.gz
+ md5sums = 1652988a8dc700fc7341573a31ad46cd
+
+pkgname = cups-ocr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..184d7014dbf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Aaron Ali <t0nedef@causal.ca>
+pkgname=cups-ocr
+pkgver=0.1.2
+pkgrel=4
+pkgdesc="Print directly to a tiff file which feeds an OCR engine which will output a text file. Modelled after cups-pdf."
+arch=('i686' 'x86_64' 'armv7h')
+url="http://github.com/t0nedef/cups-ocr/"
+license=('GPL2')
+install=$pkgname.install
+depends=('cups' 'imagemagick' 'tesseract')
+source=('https://github.com/t0nedef/cups-ocr/archive/'$pkgver'.tar.gz')
+backup=('etc/cups/cups-ocr.conf')
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make
+}
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ install -Dm700 cups-ocr ${pkgdir}/usr/lib/cups/backend/cups-ocr
+ install -Dm644 cups-ocr.conf ${pkgdir}/etc/cups/cups-ocr.conf
+ install -Dm644 CUPS-OCR.ppd ${pkgdir}/usr/share/cups/model/CUPS-OCR.ppd
+ install -Dm755 tiff-ocr ${pkgdir}/usr/bin/tiff-ocr
+}
+#
+md5sums=('1652988a8dc700fc7341573a31ad46cd')
diff --git a/cups-ocr.install b/cups-ocr.install
new file mode 100644
index 000000000000..b377ea67c92e
--- /dev/null
+++ b/cups-ocr.install
@@ -0,0 +1,16 @@
+post_install() {
+ cat << "EOF"
+-------------------------------------------------
+To use cups-ocr, restart cups and visit the cups
+web interface at http://localhost:631/
+
+You can now add a "Virtual Printer (OCR Printer)"
+and use the Postscript/Generic postscript color
+printer driver.
+
+Note that cups-ocr has a configuration
+file in /etc/cups. The default location for
+pdf output is /var/spool/cups-ocr/$username.
+-------------------------------------------------
+EOF
+}