summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD81
2 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec3d2a823df5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = curl-quiche-git
+ pkgdesc = An URL retrieval utility and library with QUIC(quiche)/HTTP3 support
+ pkgver = 8.0.1.r104.g98fac31b0
+ pkgrel = 1
+ url = https://github.com/curl/curl
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = ca-certificates
+ depends = brotli
+ depends = libbrotlidec.so
+ depends = libgssapi_krb5.so
+ depends = krb5
+ depends = libidn2
+ depends = libidn2.so
+ depends = libnghttp2
+ depends = libpsl
+ depends = libpsl.so
+ depends = libssh2
+ depends = libssh2.so
+ depends = openssl
+ depends = zlib
+ depends = zstd
+ depends = libzstd.so
+ provides = libcurl.so
+ provides = curl=8.0.1
+ conflicts = curl
+ source = curl-quiche-git::git+https://github.com/curl/curl?signed
+ validpgpkeys = 27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2
+ sha256sums = SKIP
+
+pkgname = curl-quiche-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86977467037e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: soh@AUR
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Vincent Grande <shoober420@gmail.com>
+# Contributor: Dave Reisner <dreisner@archlinux.org>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Eric Belanger <eric@archlinux.org>
+# Contributor: Lucien Immink <l.immink@student.fnt.hvu.nl>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+## GPG key: https://daniel.haxx.se/mykey.asc
+
+pkgname=curl-quiche-git
+pkgver=8.0.1.r104.g98fac31b0
+pkgrel=1
+pkgdesc="An URL retrieval utility and library with QUIC(quiche)/HTTP3 support"
+arch=('x86_64')
+url="https://github.com/curl/curl"
+license=('MIT')
+depends=(
+ 'ca-certificates' 'brotli' 'libbrotlidec.so' 'libgssapi_krb5.so'
+ 'krb5' 'libidn2' 'libidn2.so' 'libnghttp2' 'libpsl' 'libpsl.so'
+ 'libssh2' 'libssh2.so' 'openssl' 'zlib' 'zstd' 'libzstd.so')
+makedepends=('git' 'cmake')
+provides=('libcurl.so' "curl=${pkgver%.r*}")
+conflicts=('curl')
+source=("$pkgname::git+$url?signed")
+sha256sums=('SKIP')
+validpgpkeys=('27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2') ## Daniel Stenburg
+
+pkgver() {
+ git -C "$pkgname" describe --long --tags | sed 's/^curl-//;s/_/./g;s/-/.r/;s/-/./'
+}
+prepare() {
+ cd "${srcdir}"
+ if [ ! -d quiche ] ; then
+ git clone --recursive https://github.com/cloudflare/quiche
+ else
+ cd quiche
+ git pull
+ fi
+
+
+}
+build() {
+ cd quiche
+ cargo build --package quiche --release --features ffi,pkg-config-meta,qlog
+ mkdir -p quiche/deps/boringssl/src/lib
+ ln -vnf $(find target/release -name libcrypto.a -o -name libssl.a) quiche/deps/boringssl/src/lib/
+ cd ..
+ cd "$pkgname"
+
+ autoreconf -fi
+ ./configure LDFLAGS="-Wl,-rpath,$PWD/../quiche/target/release" --with-openssl=$PWD/../quiche/quiche/deps/boringssl/src --with-quiche=$PWD/../quiche/target/release \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --disable-ldap \
+ --disable-ldaps \
+ --disable-manual \
+ --enable-ipv6 \
+ --enable-threaded-resolver \
+ --with-gssapi \
+ --with-libssh2 \
+ --with-random=/dev/urandom \
+ --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt \
+ --with-openssl \
+ --enable-versioned-symbols
+
+ make
+}
+
+package() {
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install -C scripts
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 ../quiche/target/release/libquiche.so "${pkgdir}/usr/lib/libquiche.so"
+
+}
+