summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--0001-remove-error-dialog.patch28
-rw-r--r--PKGBUILD34
3 files changed, 57 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f76420cb729..511818be0e44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = cutegram-git
- pkgdesc = Telegram client by Aseman Land
- pkgver = 2.9.5.dev.r26.g20690bd
+ pkgdesc = A different telegram client from Aseman team
+ pkgver = 2.9.5+de+51+g59b53fe8
pkgrel = 1
- url = http://aseman.co/cutegram
+ url = http://aseman.co/en/products/cutegram/
arch = i686
arch = x86_64
license = GPL
makedepends = git
- depends = libqtelegram-ae-git
- depends = telegramqml-git
- depends = aseman-qt-tools-git
+ depends = libqtelegram-ae
+ depends = telegramqml
+ depends = aseman-qt-tools
+ depends = qt5-declarative
optdepends = gst-plugins-good: for audio and notification support
optdepends = gst-plugins-bad: for audio support
source = cutegram-git::git+https://github.com/Aseman-Land/Cutegram.git
- md5sums = SKIP
+ source = 0001-remove-error-dialog.patch
+ sha256sums = SKIP
+ sha256sums = 13d4d5404fa98509c908db0444e3a4cbde598f85351de9081a986857045e2487
pkgname = cutegram-git
diff --git a/0001-remove-error-dialog.patch b/0001-remove-error-dialog.patch
new file mode 100644
index 000000000000..94cac0e886f0
--- /dev/null
+++ b/0001-remove-error-dialog.patch
@@ -0,0 +1,28 @@
+From f09fb4674d4d3fc524a9aa810c216bbbecadcf4c Mon Sep 17 00:00:00 2001
+From: Chaoting Liu <brli@chakralinux.org>
+Date: Thu, 8 Dec 2016 06:31:31 +0000
+Subject: [PATCH] remove error dialog
+
+---
+ main.qml | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/main.qml b/main.qml
+index 007c8f6..d1c4c7f 100644
+--- a/main.qml
++++ b/main.qml
+@@ -35,11 +35,4 @@ AsemanApplication {
+ callback()
+ }
+ }
+-
+- MessageDialog {
+- id: errorDialog
+- title: "Fatal Error"
+- text: "Cutegram could not be started. Additional information:"
+- onAccepted: app.exit(1)
+- }
+ }
+--
+2.10.0
+
diff --git a/PKGBUILD b/PKGBUILD
index c5230a5b07b8..57c37a3c8786 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,49 @@
-# Maintainer: Jiachen Yang <farseerfc@gmail.com>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Jiachen Yang <farseerfc@gmail.com>
# Contributor: Llumex03
# Maintainer in Chakra: gnastyle
# Contributor in Chakra: FranzMari from Chakra
# Contributor in Chakra: danyf90 <daniele.formihelli@gmail.com>
# Contributor in Chakra: totoloco <totoloco@gmx.com>
-pkgname=cutegram-git
-pkgver=2.9.5.dev.r26.g20690bd
+_pkgname=cutegram
+pkgname=$_pkgname-git
+pkgver=2.9.5+de+51+g59b53fe8
pkgrel=1
-pkgdesc="Telegram client by Aseman Land"
+pkgdesc="A different telegram client from Aseman team"
arch=('i686' 'x86_64')
-url="http://aseman.co/cutegram"
+url="http://aseman.co/en/products/cutegram/"
license=('GPL')
-depends=('libqtelegram-ae-git' 'telegramqml-git' 'aseman-qt-tools-git')
+depends=('libqtelegram-ae' 'telegramqml' 'aseman-qt-tools' 'qt5-declarative')
optdepends=('gst-plugins-good: for audio and notification support'
'gst-plugins-bad: for audio support')
makedepends=('git')
-source=("${pkgname}"::"git+https://github.com/Aseman-Land/Cutegram.git")
-md5sums=('SKIP')
+source=("${pkgname}"::"git+https://github.com/Aseman-Land/Cutegram.git"
+ '0001-remove-error-dialog.patch')
+sha256sums=('SKIP'
+ '13d4d5404fa98509c908db0444e3a4cbde598f85351de9081a986857045e2487')
pkgver() {
cd "${srcdir}/${pkgname}"
- ( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long | sed 's/\([^-]*-g\)/\1/;s/-/+/g' | sed 's/.stable//g' | sed 's/v//g'
}
prepare() {
cd "${srcdir}/${pkgname}"
+
+ patch -Np1 -i $srcdir/0001-remove-error-dialog.patch
+ # change the heading application
+ sed 's,qmlscene,qmlscene-qt5,g' -i cutegram.pro
mkdir -p build
}
build() {
cd "${srcdir}/${pkgname}/build"
- qmake-qt5 .. QMAKE_CFLAGS_ISYSTEM= CONFIG+=binaryMode PREFIX=/usr
+ qmake-qt5 QMAKE_CFLAGS_ISYSTEM= PREFIX=/usr DEFINES+=WEBENGINE_ASEMAN_WEBGRABBER CONFIG+=binaryMode ..
make
}
package() {
cd "${srcdir}/${pkgname}/build"
- # make INSTALL_ROOT="${pkgdir}" install
- install -Dm755 cutegram "${pkgdir}/usr/bin/cutegram"
+ make INSTALL_ROOT="${pkgdir}" install
}