summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cfd26a6bb12..9d4f434a1099 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cutelyst
pkgdesc = A Web Framework built on top of Qt, using the simple approach of Catalyst (Perl) framework.
- pkgver = 2.14.2
- pkgrel = 2
+ pkgver = 3.0.0
+ pkgrel = 1
url = http://cutelyst.org
arch = i686
arch = x86_64
@@ -10,14 +10,11 @@ pkgbase = cutelyst
makedepends = cmake
makedepends = doxygen
makedepends = graphviz
- depends = qt5-base
- depends = grantlee
- depends = uwsgi
- source = https://github.com/cutelyst/cutelyst/archive/v2.14.2.tar.gz
- sha512sums = 3e192bb9d1925896e05488d7867bd36845d2fb0276fa4725ac841526095628994a339b1b92b6a9615d71788f01bb68af92ae131a55ce3aa6774f840fc80540ee
+ depends = qt6-base
+ source = https://github.com/cutelyst/cutelyst/archive/v3.0.0.tar.gz
+ sha512sums = 1bb719949caed7ad6cf5f6bf1ace4e4a9531970cc4f1572e19a86913797e871d447790d676777b46baa35d7a5897111cd3f313b1c8a5010e072f2680191e4e7b
pkgname = cutelyst
pkgname = cutelyst-docs
pkgdesc = Doxygen HTML API Documentation
-
diff --git a/PKGBUILD b/PKGBUILD
index f64ec86dd266..1d1a0658877b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgbase=cutelyst
pkgname=('cutelyst' 'cutelyst-docs')
-pkgver=2.14.2
-pkgrel=2
+pkgver=3.0.0
+pkgrel=1
pkgdesc='A Web Framework built on top of Qt, using the simple approach of Catalyst (Perl) framework.'
arch=('i686' 'x86_64')
url="http://cutelyst.org"
license=('LGPL2.1')
-depends=('qt5-base' 'grantlee' 'uwsgi')
+depends=('qt6-base')
makedepends=('pkgconf' 'cmake' 'doxygen' 'graphviz')
source=("https://github.com/cutelyst/cutelyst/archive/v${pkgver}.tar.gz")
@@ -19,8 +19,7 @@ build() {
cd build
cmake \
-DCMAKE_BUILD_TYPE=Release \
- -DPLUGIN_UWSGI=on \
- -DPLUGIN_VIEW_GRANTLEE=on \
+ -DPLUGIN_UWSGI=off \
-DPLUGIN_CSRFPROTECTION=on \
-DCMAKE_INSTALL_PREFIX=/usr ".."
make
@@ -42,4 +41,4 @@ package_cutelyst() {
cd "$srcdir/${pkgname}-${pkgver}/build"
make DESTDIR="$pkgdir/" install
}
-sha512sums=('3e192bb9d1925896e05488d7867bd36845d2fb0276fa4725ac841526095628994a339b1b92b6a9615d71788f01bb68af92ae131a55ce3aa6774f840fc80540ee')
+sha512sums=('1bb719949caed7ad6cf5f6bf1ace4e4a9531970cc4f1572e19a86913797e871d447790d676777b46baa35d7a5897111cd3f313b1c8a5010e072f2680191e4e7b')