summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0aa6393c61c9..a63cdd027134 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cutter-test_framework
pkgdesc = cutter is a C/C++ unit test framework.
- pkgver = 1.2.7
+ pkgver = 1.2.8
pkgrel = 1
url = http://cutter.sourceforge.net/index.html
arch = i686
@@ -20,8 +20,8 @@ pkgbase = cutter-test_framework
optdepends = cairo
optdepends = pango
optdepends = ruby
- source = https://github.com/clear-code/cutter/releases/download/1.2.7/cutter-1.2.7.tar.gz
- sha1sums = a6294b713bc4c5574a6cf6f4ba6be1ffeabaa3b2
+ source = https://github.com/clear-code/cutter/archive/refs/tags/1.2.8.tar.gz
+ sha1sums = 06c92b3165b3174cd1ac970efd17a11570db8356
+ sha256sums = af29d3d61076fc03313fc1b8da76aa8b884edf683e684898be5d33ba8440df14
pkgname = cutter-test_framework
-
diff --git a/PKGBUILD b/PKGBUILD
index f07b74b8df8f..401e19465e4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
pkgname=cutter-test_framework
-pkgver=1.2.7
+pkgver=1.2.8
pkgrel=1
pkgdesc="cutter is a C/C++ unit test framework."
targzname=cutter
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="http://cutter.sourceforge.net/index.html"
license=('FDL1.3' 'LGPL3')
-source=("https://github.com/clear-code/cutter/releases/download/1.2.7/cutter-${pkgver}.tar.gz")
-builddepends=(perl-xml-parser)
+source=("https://github.com/clear-code/cutter/archive/refs/tags/${pkgver}.tar.gz")
+builddepends=(perl-xml-parser gtk-doc)
depends=(glib2 intltool perl pkg-config libsoup gettext perl-xml-parser)
optdepends=(gtk2 cairo pango ruby)
build() {
cd $srcdir/$targzname-$pkgver
+ ./autogen.sh
./configure --prefix=/usr \
--localstatedir=/var \
--sysconfdir=/etc \
@@ -26,4 +27,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha1sums=('a6294b713bc4c5574a6cf6f4ba6be1ffeabaa3b2')
+sha1sums=('06c92b3165b3174cd1ac970efd17a11570db8356')
+sha256sums=('af29d3d61076fc03313fc1b8da76aa8b884edf683e684898be5d33ba8440df14')