summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4f4da53ca10..65be2bb5060b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = cylon
pkgdesc = Updates, Maintenance, backup and system checks in a menu driven Bash script
- pkgver = 2.3
- pkgrel = 2
+ pkgver = 3.0
+ pkgrel = 1
url = https://github.com/gavinlyonsrepo/cylon
arch = any
license = GPL
optdepends = cower: AUR package for AUR work
optdepends = gdrive: AUR package for google drive backup
optdepends = lostfiles: AUR package for finding lost files
+ optdepends = pacaur: AUR helper
optdepends = rmlint: Finds lint and other unwanted
optdepends = rkhunter: finds root kits malware
optdepends = clamav: used for finding malware
@@ -15,8 +16,13 @@ pkgbase = cylon
optdepends = gnu-netcat: used for checking network
optdepends = ccrypt: used for encrypting
optdepends = rsync: used for backup
- source = https://github.com/gavinlyonsrepo/cylon/archive/2.3.tar.gz
- md5sums = b3a4977ddd244dc41c3d1105b9736f7f
+ optdepends = inxi: system information viewer
+ optdepends = htop: interactive process viewer
+ optdepends = wavemon: wireless network monitor
+ optdepends = speedtest-cli: internet bandwidth
+ optdepends = lynis: system audit tool
+ source = https://github.com/gavinlyonsrepo/cylon/archive/3.0.tar.gz
+ md5sums = 53233eeb97e9982176e4269ad3a1df2f
pkgname = cylon
diff --git a/PKGBUILD b/PKGBUILD
index 38d65062e8a7..b7ca8f0fdb53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: gavin lyons <glyons66@hotmail.com>
# https://github.com/gavinlyonsrepo/cylon
pkgname=cylon
-pkgver=2.3
-pkgrel=2
+pkgver=3.0
+pkgrel=1
pkgdesc="Updates, Maintenance, backup and system checks in a menu driven Bash script"
arch=('any')
url="https://github.com/gavinlyonsrepo/cylon"
@@ -11,6 +11,7 @@ optdepends=(
'cower: AUR package for AUR work'
'gdrive: AUR package for google drive backup'
'lostfiles: AUR package for finding lost files'
+ 'pacaur: AUR helper'
'rmlint: Finds lint and other unwanted'
'rkhunter: finds root kits malware'
'clamav: used for finding malware'
@@ -18,12 +19,18 @@ optdepends=(
'gnu-netcat: used for checking network'
'ccrypt: used for encrypting'
'rsync: used for backup'
+ 'inxi: system information viewer'
+ 'htop: interactive process viewer'
+ 'wavemon: wireless network monitor'
+ 'speedtest-cli: internet bandwidth'
+ 'lynis: system audit tool'
+
)
source=("https://github.com/gavinlyonsrepo/cylon/archive/$pkgver.tar.gz")
-md5sums=('b3a4977ddd244dc41c3d1105b9736f7f')
+md5sums=('53233eeb97e9982176e4269ad3a1df2f')
package() {
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "$srcdir/${pkgname}-${pkgver}"
install -D -m755 Cylon.sh "$pkgdir"/usr/bin/"${pkgname}"
install -D -m644 Readme.md "$pkgdir/usr/share/doc/${pkgname}/Readme.md"
install -D -m644 changelog.md "$pkgdir/usr/share/doc/${pkgname}/changelog.md"