summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d85208cca1da..121aa5ef96d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,6 @@ pkgbase = cylon
url = https://github.com/gavinlyonsrepo/cylon
arch = any
license = GPL
- makedepends = git
optdepends = cower: AUR package for AUR work
optdepends = gdrive: AUR package for google drive backup
optdepends = lostfiles: AUR package for finding lost files
@@ -14,8 +13,8 @@ pkgbase = cylon
optdepends = clamav: used for finding malware
optdepends = bleachbit: used for system clean
optdepends = gnu-netcat: used for checking network
- source = git://github.com/gavinlyonsrepo/cylon.git
- md5sums = SKIP
+ source = https://github.com/gavinlyonsrepo/cylon/archive/2.1.tar.gz
+ md5sums = 7e6973306b95e8d91a45b64253ac55cd
pkgname = cylon
diff --git a/PKGBUILD b/PKGBUILD
index 3a5e9044ebc4..c06e908c5065 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,10 @@
pkgname=cylon
pkgver=2.1
pkgrel=9
-epoch=
pkgdesc="Maintenance , backup and system checks in a menu driven Bash script"
arch=('any')
url="https://github.com/gavinlyonsrepo/cylon"
license=('GPL')
-makedepends=('git')
optdepends=(
'cower: AUR package for AUR work'
'gdrive: AUR package for google drive backup'
@@ -19,13 +17,13 @@ optdepends=(
'bleachbit: used for system clean'
'gnu-netcat: used for checking network'
)
-source=("git://github.com/gavinlyonsrepo/${pkgname}.git")
-md5sums=('SKIP')
+#source=("git://github.com/gavinlyonsrepo/${pkgname}.git")
+source=("https://github.com/gavinlyonsrepo/cylon/archive/$pkgver.tar.gz")
+md5sums=('7e6973306b95e8d91a45b64253ac55cd')
package() {
- cd "$srcdir/${pkgname}"
+ cd "$srcdir/${pkgname}-${pkgver}"
install -D -m755 Cylon.sh "$pkgdir"/usr/bin/"${pkgname}"
- mkdir -p "$HOME/.config/cylon/"
install -D -m644 Readme.md "$HOME"/.config/cylon/cylonReadme.md
install -D -m644 License.md "$pkgdir/usr/share/licenses/${pkgname}/License.md"
}