summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 26 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68dbfd5c428f..50e8c9f21082 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
pkgbase = cython-git
pkgdesc = C-Extensions for Python
- pkgver = 3.0.0b2.r40.gd0bbecb7f
+ pkgver = 3.0.12.r813.g7687821df
pkgrel = 1
url = https://cython.org/
arch = i686
arch = x86_64
- license = Apache
+ license = Apache-2.0
+ checkdepends = gdb
+ checkdepends = python-numpy
+ checkdepends = python-pytest
+ checkdepends = python-tests
makedepends = git
makedepends = python-build
makedepends = python-installer
+ makedepends = python-setuptools
makedepends = python-wheel
depends = python
- provides = cython=3.0.0b2.r40.gd0bbecb7f
+ provides = cython=3.0.12.r813.g7687821df
conflicts = cython
source = git+https://github.com/cython/cython.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7126f7b933ed..99786014f8fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=cython-git
-pkgver=3.0.0b2.r40.gd0bbecb7f
+pkgver=3.0.12.r813.g7687821df
pkgrel=1
pkgdesc="C-Extensions for Python"
arch=('i686' 'x86_64')
url="https://cython.org/"
-license=('Apache')
+license=('Apache-2.0')
depends=('python')
-makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+checkdepends=('gdb' 'python-numpy' 'python-pytest' 'python-tests')
provides=("cython=$pkgver")
conflicts=('cython')
source=("git+https://github.com/cython/cython.git")
@@ -18,7 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "cython"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {
@@ -30,6 +34,14 @@ build() {
--no-isolation
}
+check() {
+ cd "cython"
+
+ #make \
+ # test \
+ # --no-pyregr
+}
+
package() {
cd "cython"
@@ -39,7 +51,7 @@ package() {
dist/*.whl
for f in cygdb cython cythonize; do
- mv "$pkgdir/usr/bin"/$f "$pkgdir/usr/bin"/${f}3
- ln -s ${f}3 "$pkgdir/usr/bin"/$f
+ mv "$pkgdir/usr/bin/$f" "$pkgdir/usr/bin/${f}3"
+ ln -s "${f}3" "$pkgdir/usr/bin/$f"
done
}