summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42edf7a4fd52..19be26aa12b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
# Generated by mksrcinfo v8
-# Mon Apr 25 21:46:57 UTC 2016
+# Sun Sep 10 18:31:42 UTC 2017
pkgbase = datamash-git
pkgdesc = A command-line program which performs numeric, textual and statistical operations on plain text data.
- pkgver = v1.0.6.r54.gf8ae71f
- pkgrel = 3
+ pkgver = 1.2.r4.gfd49457
+ pkgrel = 1
url = https://www.gnu.org/software/datamash/
- install = datamash.install
- arch = any
+ arch = x86_64
+ arch = i686
license = GPL
makedepends = git
makedepends = gperf
@@ -15,7 +15,7 @@ pkgbase = datamash-git
depends = glibc
provides = datamash
conflicts = datamash
- source = git://git.sv.gnu.org/datamash.git
+ source = git+https://git.savannah.gnu.org/git/datamash.git
sha256sums = SKIP
pkgname = datamash-git
diff --git a/PKGBUILD b/PKGBUILD
index 93ff811ba67c..e23ee2d94977 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
-# Maintainer: jyantis <yantis@yantis.net>
+# Maintainer: Alad Wenter <alad@mailbox.org>
+# Maintainer: jyantis <yantis@yantis.net>
# Based on the PKGBUILD for datamash from
# Timothy Rice <t.rice@ms.unimelb.edu.au>
-
pkgname=datamash-git
-pkgver=v1.0.6.r54.gf8ae71f
-pkgrel=3
+pkgver=1.2.r4.gfd49457
+pkgrel=1
pkgdesc='A command-line program which performs numeric, textual and statistical operations on plain text data.'
-arch=('any')
+arch=('x86_64' 'i686')
url='https://www.gnu.org/software/datamash/'
license=('GPL')
-source=('git://git.sv.gnu.org/datamash.git')
+source=('git+https://git.savannah.gnu.org/git/datamash.git')
sha256sums=('SKIP')
depends=('glibc')
+# XXX rsync/wget are only needed for .po files in bootstrap.
makedepends=('git' 'gperf' 'rsync' 'wget')
conflicts=('datamash')
provides=('datamash')
-install=datamash.install
+
pkgver() {
cd datamash
- set -o pipefail
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
- # git describe --long | sed -r 's/^v//' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//; s/-/.r/; s/-/./'
}
build() {