summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--DBGlass.desktop10
-rw-r--r--PKGBUILD30
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f496b2aff7ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dbglass-bin
+ pkgdesc = Simple cross-platform PostgreSQL client. Built with Electron, React, Redux, FixedDataTable.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/web-pal/DBGlass
+ arch = x86_64
+ license = MIT
+ makedepends = npm
+ source = https://github.com/web-pal/DBGlass/releases/download/v0.1.0-beta.6/linux-x64.tar.gz
+ source = DBGlass.desktop
+ sha1sums = 2477e8974f7309dd53cefe6eaa12761cd20b662b
+ sha1sums = cba58f494602974cd968777ece6cb4ec963492cc
+
+pkgname = dbglass-bin
+
diff --git a/DBGlass.desktop b/DBGlass.desktop
new file mode 100644
index 000000000000..76c29a288698
--- /dev/null
+++ b/DBGlass.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=DBGlass
+Comment=Simple cross-platform PostgreSQL client
+Exec=dbglass
+Icon=DBGlass
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=Development;SQL;
+MimeType=text/plain;
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..823c430d7eff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: voropaev.roma@gmail.com
+
+pkgname=dbglass-bin
+pkgver=0.1.0
+_pkgver_extra=beta.6
+pkgrel=1
+pkgdesc="Simple cross-platform PostgreSQL client. Built with Electron, React, Redux, FixedDataTable."
+license=('MIT')
+arch=('x86_64')
+url="https://github.com/web-pal/DBGlass"
+makedepends=('npm')
+source=("${url}/releases/download/v${pkgver}-${_pkgver_extra}/linux-x64.tar.gz" "DBGlass.desktop")
+sha1sums=('2477e8974f7309dd53cefe6eaa12761cd20b662b'
+ 'cba58f494602974cd968777ece6cb4ec963492cc')
+
+package() {
+ # Copy files to /opt
+ mkdir -p "${pkgdir}/opt/${pkgname}"
+ cp --preserve=mode -r DBGlass-linux-x64/* "${pkgdir}/opt/${pkgname}"
+
+ # Copy icon
+ install -Dm755 DBGlass-linux-x64/resources/app/logo/logo.png "${pkgdir}/usr/share/icons/hicolor/256x256/dbglass.png"
+
+ # Exec link
+ mkdir -p "${pkgdir}/usr/local/bin"
+ ln -s "${pkgdir}/opt/${pkgname}/DBGlass" "${pkgdir}/usr/local/bin/dbglass"
+
+ # Desktop file
+ install -Dm755 DBGlass.desktop "${pkgdir}/usr/share/applications/DBGlass.desktop"
+}