summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 9 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d627320e9ce..f2aa8267f20b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dbus-cpp
pkgdesc = A header-only dbus-binding leveraging C++-11
- pkgver = 5.0.1
+ pkgver = 5.0.3
pkgrel = 1
url = https://gitlab.com/ubports/core/lib-cpp/dbus-cpp
arch = x86_64
@@ -12,9 +12,7 @@ pkgbase = dbus-cpp
depends = dbus
depends = libxml2
depends = process-cpp
- source = https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/dbus-cpp/5.0.1-4/dbus-cpp_5.0.1.orig.tar.gz
- source = https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/dbus-cpp/5.0.1-4/dbus-cpp_5.0.1-4.debian.tar.xz
- sha256sums = 37f0391cad90f419db37c7c93c2726d832ef6bf29c420a57d6d42cb1f9d42e22
- sha256sums = 96067d7efe657bab84eb127f05a89d700e218583ea4982d9d021d1ea6baea141
+ source = https://gitlab.com/ubports/core/lib-cpp/dbus-cpp/-/archive/5.0.3/dbus-cpp-5.0.3.tar.gz
+ sha256sums = 465ca23024c8f245d13a0afd454da17e6344d0c78941d99b7c9323a17f6e82ba
pkgname = dbus-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 134c9dea0c21..380f2fa46abd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=dbus-cpp
pkgdesc='A header-only dbus-binding leveraging C++-11'
-pkgver=5.0.1
+pkgver=5.0.3
pkgrel=1
url='https://gitlab.com/ubports/core/lib-cpp/dbus-cpp'
arch=('x86_64' 'i686')
@@ -12,28 +12,20 @@ license=('LGPL3')
groups=('lib-cpp')
depends=('dbus' 'libxml2' 'process-cpp')
makedepends=('cmake' 'boost')
-source=('https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/dbus-cpp/5.0.1-4/dbus-cpp_5.0.1.orig.tar.gz'
- 'https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/dbus-cpp/5.0.1-4/dbus-cpp_5.0.1-4.debian.tar.xz')
-sha256sums=('37f0391cad90f419db37c7c93c2726d832ef6bf29c420a57d6d42cb1f9d42e22'
- '96067d7efe657bab84eb127f05a89d700e218583ea4982d9d021d1ea6baea141')
+source=('https://gitlab.com/ubports/core/lib-cpp/dbus-cpp/-/archive/5.0.3/dbus-cpp-5.0.3.tar.gz')
+sha256sums=('465ca23024c8f245d13a0afd454da17e6344d0c78941d99b7c9323a17f6e82ba')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
- # Apply debian patches and don't build tests
- patch -p1 < ../debian/patches/dont-build-with-werror.patch
- patch -p1 < ../debian/patches/0001_explicitly-declare-copy-constructor.patch
- patch -p1 < ../debian/patches/0002_fix-build-with-boost-1.66.0-and-above.patch
- sed -e '105d' -i CMakeLists.txt
+ sed -e '82d' -i CMakeLists.txt
}
build() {
mkdir -p "${srcdir}/${pkgname}-${pkgver}/_build"
cd "${srcdir}/${pkgname}-${pkgver}/_build"
- cmake -DDBUS_CPP_VERSION_MAJOR='5' -DDBUS_CPP_VERSION_MINOR='0' \
- -DDBUS_CPP_VERSION_PATCH='1' -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_LIBEXECDIR="lib/${pkgname}" ..
+ cmake -DCMAKE_INSTALL_LIBEXECDIR="lib/${pkgname}" \
+ -DCMAKE_BUILD_TYPE=Release ..
cmake --build .
}