summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD8
2 files changed, 42 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcf1d1c65507..b4a7831ab302 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -35,3 +35,40 @@ pkgbase = deal-ii
pkgname = deal-ii
+pkgbase = deal-ii
+ pkgdesc = An Open Source Finite Element Differential Equations Analysis Library
+ pkgver = 9.1.1
+ pkgrel = 1
+ url = http://www.dealii.org/
+ install = deal-ii.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ depends = boost
+ optdepends = arpack: Fortran77 subroutines designed to solve large scale eigenvalue problems
+ optdepends = assimp: Library to import various well-known 3D model formats in an uniform manner
+ optdepends = gsl: A modern numerical library for C and C++ programmers
+ optdepends = hdf5-openmpi: General purpose library and file format for storing scientific data
+ optdepends = intel-tbb: High level abstract threading library
+ optdepends = lapack: Linear Algebra PACKage
+ optdepends = metis: partitioning graphs, finite element meshes, fill reducing orderings for sparse matrices.
+ optdepends = muparser: A fast math parser library
+ optdepends = nanoflann: a C++ header-only library for Nearest Neighbor (NN) search wih KD-trees
+ optdepends = netcdf-cxx-legacy: Legacy NetCDF C++ bindings
+ optdepends = openmpi: High performance message passing library (MPI)
+ optdepends = opencascade: Open CASCADE Technology, 3D modeling & numerical simulation
+ optdepends = p4est-deal-ii: The parallel forest (p4est) library, built to work with deal.II
+ optdepends = parmetis: A parallel graph partitioning library
+ optdepends = petsc: Portable, extensible toolkit for scientific computation
+ optdepends = scalapack: subset of scalable LAPACK routines redesigned for distributed memory MIMD parallel computers
+ optdepends = slepc: Scalable library for Eigenvalue problem computations
+ optdepends = symengine: Fast symbolic manipulation library
+ optdepends = trilinos: object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems
+ optdepends = suitesparse: A collection of sparse matrix libraries
+ optdepends = zlib: Compression library implementing the deflate compression method found in gzip and PKZIP
+ source = https://github.com/dealii/dealii/releases/download/v9.1.1/dealii-9.1.1.tar.gz
+ sha1sums = 58ae55a3cb70c8a36f74cb0c737a0d29b281eb94
+
+pkgname = deal-ii
+
diff --git a/PKGBUILD b/PKGBUILD
index d91b121b242f..5ffa34607ac0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -101,7 +101,7 @@ build() {
sed -i '/ENABLE_IF_LINKS(DEAL_II_LINKER_FLAGS "-Wl,--as-needed")/d' \
${srcdir}/${_realname}-$pkgver/cmake/setup_compiler_flags_gnu.cmake
- sed -i '121ifedisableexcept(FE_INVALID);\n' \
+ sed -i '122ifedisableexcept(FE_INVALID);\n' \
${srcdir}/${_realname}-$pkgver/tests/quick_tests/scalapack.cc
@@ -141,9 +141,11 @@ package() {
make DESTDIR="${pkgdir}" install
# delete extra files that deal.II installs into the top level directory
- rm "${pkgdir}/${installation_prefix}/LICENSE"
+ rm "${pkgdir}/${installation_prefix}/LICENSE.md"
rm "${pkgdir}/${installation_prefix}/README.md"
+ rm "${pkgdir}/${installation_prefix}/detailed.log"
+ rm "${pkgdir}/${installation_prefix}/summary.log"
install -D -m755 "${srcdir}/build/deal-ii.sh" "${pkgdir}/etc/profile.d/deal-ii.sh"
- install -D -m644 "${srcdir}/${_realname}-$pkgver/LICENSE" "${pkgdir}/usr/share/licenses/${_realname}-$pkgver/LICENSE"
+ install -D -m644 "${srcdir}/${_realname}-$pkgver/LICENSE.md" "${pkgdir}/usr/share/licenses/${_realname}-$pkgver/LICENSE.md"
}