summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rwxr-xr-x.gitignore4
-rwxr-xr-xPKGBUILD51
-rwxr-xr-xdectalk.desktop28
-rw-r--r--dectalk.patch47
-rw-r--r--paul.pngbin0 -> 2583 bytes
6 files changed, 154 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06daab705a90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = dectalk-git
+ pkgdesc = Modern builds for the 90s/00s DECtalk text-to-speech application.
+ pkgver = 2023.10.30.r5.g2de226f1
+ pkgrel = 1
+ url = https://github.com/dectalk/dectalk
+ arch = i686
+ arch = x86_64
+ license = Proprietary
+ makedepends = make
+ makedepends = git
+ makedepends = unzip
+ depends = alsa-lib
+ depends = libpulse
+ provides = dectalk
+ source = git+https://github.com/dectalk/dectalk
+ source = dectalk.patch
+ source = dectalk.desktop
+ source = paul.png
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = dectalk-git
diff --git a/.gitignore b/.gitignore
new file mode 100755
index 000000000000..131e7720bf1f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+dectalk/
+src/
+pkg/
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..c6c305e293ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Kaydax <contact+aur@kaydax.xyz>
+
+_pkgname=dectalk
+pkgname=${_pkgname}-git
+pkgver=2023.10.30.r5.g2de226f1
+pkgrel=1
+pkgdesc="Modern builds for the 90s/00s DECtalk text-to-speech application."
+arch=('i686' 'x86_64')
+url="https://github.com/dectalk/dectalk"
+license=('Proprietary')
+provides=('dectalk')
+depends=('alsa-lib' 'libpulse')
+makedepends=('make' 'git' 'unzip')
+optdepend=(
+ 'gtk2: Needed for graphical interface'
+)
+source=("git+https://github.com/dectalk/dectalk"
+ "dectalk.patch"
+ "dectalk.desktop"
+ "paul.png")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "dectalk"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ patch --directory="$_pkgname" --forward --strip=1 --input="${srcdir}/dectalk.patch"
+ cd "dectalk/src"
+ autoreconf -si
+ ./configure
+}
+
+build() {
+ cd "dectalk/src"
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/share/applications"
+ mkdir -p "$pkgdir/usr/share/pixmaps"
+ cp "dectalk.desktop" "$pkgdir/usr/share/applications/dectalk.desktop"
+ cp "paul.png" "$pkgdir/usr/share/pixmaps/paul.png"
+ cd "dectalk/src"
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/dectalk.desktop b/dectalk.desktop
new file mode 100755
index 000000000000..84b4de840b9c
--- /dev/null
+++ b/dectalk.desktop
@@ -0,0 +1,28 @@
+[Desktop Entry]
+
+# The type as listed above
+Type=Application
+
+# The version of the desktop entry specification to which this file complies
+Version=1.0
+
+# The name of the application
+Name=Dectalk GSpeak
+
+# A comment which can/will be used as a tooltip
+Comment=GUI Application for Dectalk
+
+# The path to the folder in which the executable is run
+Path=/opt/dectalk
+
+# The executable of the application, possibly with arguments.
+Exec=gspeak
+
+# The name of the icon that will be used to display this entry
+Icon=paul
+
+# Describes whether this application needs to be run in a terminal or not
+Terminal=false
+
+# Describes the categories in which this entry should be shown
+Categories=Utilities
diff --git a/dectalk.patch b/dectalk.patch
new file mode 100644
index 000000000000..3956132ccd7c
--- /dev/null
+++ b/dectalk.patch
@@ -0,0 +1,47 @@
+diff --color --unified --recursive --text dectalk.old/src/Makefile.in dectalk.new/src/Makefile.in
+--- dectalk.old/src/Makefile.in 2023-12-28 14:37:17.607385115 -0500
++++ dectalk.new/src/Makefile.in 2023-12-28 14:38:12.975301780 -0500
+@@ -111,12 +111,37 @@
+ echo "LANG:fr,French" >> $(DESTDIR)$(INSTALL_PREFIX)/DECtalk.conf
+
+ -mkdir -p $(DESTDIR)/usr/bin/
+- -ln -sf $(DESTDIR)$(INSTALL_PREFIX)/gspeak $(DESTDIR)/usr/bin/gspeak
+- -ln -sf $(DESTDIR)$(INSTALL_PREFIX)/say $(DESTDIR)/usr/bin/say
+- -ln -sf $(DESTDIR)$(INSTALL_PREFIX)/windic $(DESTDIR)/usr/bin/windic
+- -ln -sf $(DESTDIR)$(INSTALL_PREFIX)/dtmemory $(DESTDIR)/usr/bin/dtmemory
+- -ln -sf $(DESTDIR)$(INSTALL_PREFIX)/aclock $(DESTDIR)/usr/bin/aclock
+- -ln -sf $(DESTDIR)$(INSTALL_PREFIX)/tools/* $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/gspeak $(DESTDIR)/usr/bin/gspeak
++ -ln -sf $(INSTALL_PREFIX)/say $(DESTDIR)/usr/bin/say
++ -ln -sf $(INSTALL_PREFIX)/windic $(DESTDIR)/usr/bin/windic
++ -ln -sf $(INSTALL_PREFIX)/dtmemory $(DESTDIR)/usr/bin/dtmemory
++ -ln -sf $(INSTALL_PREFIX)/aclock $(DESTDIR)/usr/bin/aclock
++ -ln -sf $(INSTALL_PREFIX)/tools/dic_fr $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/dic_gr $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/dic_la $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/dic_sp $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/dic_uk $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/dic_us $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/dump_vdf $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/mfg_load $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/say_demo_fr $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/say_demo_gr $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/say_demo_la $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/say_demo_sp $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/say_demo_uk $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/say_demo_us $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/tunecheck_fr $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/tunecheck_gr $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/tunecheck_la $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/tunecheck_sp $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/tunecheck_uk $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/tunecheck_us $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/udic_fr $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/udic_gr $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/udic_la $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/udic_sp $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/udic_uk $(DESTDIR)/usr/bin/
++ -ln -sf $(INSTALL_PREFIX)/tools/udic_us $(DESTDIR)/usr/bin/
+
+ english_release:
+ $(MAKE) -f Makefile.sub "LANGUAGE=ENGLISH -DENGLISH_US -DACNA" \
diff --git a/paul.png b/paul.png
new file mode 100644
index 000000000000..a88813ebd308
--- /dev/null
+++ b/paul.png
Binary files differ