summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4acb9cf613e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = deepin-dock-plugin-netspeedandsysteminfo
+ pkgdesc = A plugin for deepin dock, Displays Current Netspeed and General SystemInfo
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Bearbobs/deepin-dock-plugin-netspeedandsysteminfo
+ arch = x86_64
+ makedepends = git
+ makedepends = qt5-base
+ makedepends = qt5-tools
+ makedepends = dtkcore
+ depends = deepin-dock
+ depends = pacman-contrib
+ source = deepin-dock-plugin-netspeedandsysteminfo-1.0.0.tar.gz::https://github.com/Bearbobs/deepin-dock-plugin-netspeedandsystemInfo/archive/1.0.0.tar.gz
+ md5sums = 3a6dc585c2bcfd73dcf37da2f413b1fd
+
+pkgname = deepin-dock-plugin-netspeedandsysteminfo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0323b1f4918e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: BearBobs <kapoor.anuj0@gmail.com>
+
+pkgname=deepin-dock-plugin-netspeedandsysteminfo
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A plugin for deepin dock, Displays Current Netspeed and General SystemInfo"
+arch=('x86_64')
+url="https://github.com/Bearbobs/deepin-dock-plugin-netspeedandsysteminfo"
+depends=('deepin-dock' 'pacman-contrib')
+makedepends=('git' 'qt5-base' 'qt5-tools' 'dtkcore')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Bearbobs/deepin-dock-plugin-netspeedandsysteminfo/archive/${pkgver}.tar.gz")
+md5sums=('88d6e4899c6f56fd675250bababd92b9')
+
+build() {
+
+ qmake "$srcdir/$pkgname-$pkgver/"
+ make ${MAKEFLAGS}
+}
+
+package(){
+ make INSTALL_ROOT="$pkgdir" install
+}