summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8113052dccaa..e4596e9dc48e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,15 +10,12 @@ pkgbase = deepin-launchpad-git
makedepends = git
makedepends = cmake
makedepends = ninja
- makedepends = qt5-tools
- depends = qt5-svg
- depends = qt5-quickcontrols
+ makedepends = qt6-tools
+ depends = qt6-svg
+ depends = qt6-declarative
depends = appstream-qt
- depends = dtkdeclarative
- depends = dtkgui
- depends = qt5-base
- depends = qt5-x11extras
- depends = qt5-svg
+ depends = dtk6declarative
+ depends = dtk6gui
provides = deepin-launchpad
conflicts = deepin-launcher
source = git+https://github.com/linuxdeepin/dde-launchpad
diff --git a/PKGBUILD b/PKGBUILD
index 3d820e4e3dc7..574aea44d611 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,13 @@ pkgdesc='Deepin desktop-environment - Launchpad module'
arch=('x86_64' 'aarch64')
url="https://github.com/linuxdeepin/dde-launchpad"
license=('GPL3')
-depends=('qt5-svg'
- 'qt5-quickcontrols'
+depends=('qt6-svg'
+ 'qt6-declarative'
'appstream-qt'
- 'dtkdeclarative'
- 'dtkgui'
- 'qt5-base'
- 'qt5-x11extras'
- 'qt5-svg'
+ 'dtk6declarative'
+ 'dtk6gui'
)
-makedepends=('git' 'cmake' 'ninja' 'qt5-tools')
+makedepends=('git' 'cmake' 'ninja' 'qt6-tools')
conflicts=('deepin-launcher')
provides=('deepin-launchpad')
groups=('deepin-git')
@@ -32,7 +29,7 @@ pkgver() {
build() {
cd $sourcedir
- cmake . -GNinja -DCMAKE_INSTALL_PREFIX=/usr
+ cmake . -GNinja -DCMAKE_INSTALL_PREFIX=/usr -DPREFER_QT_5=OFF
ninja
}