summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD51
-rw-r--r--deluge-web.service10
-rw-r--r--deluged.service11
4 files changed, 37 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b069253e3ec3..f5388a4fd8fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,30 @@
pkgbase = deluge-git
pkgdesc = A BitTorrent client with multiple user interfaces in a client/server model (git version, 'develop' branch)
- pkgver = 2.0.4.dev23.g2f1c008a2
+ pkgver = 2.1.1.dev61.g800111062
pkgrel = 1
epoch = 1
url = https://deluge-torrent.org/
arch = any
license = GPL3
- checkdepends = python-pytest-twisted
- checkdepends = python-pytest-cov
- checkdepends = python-hypothesis
- checkdepends = python-mock
- checkdepends = python-cairo
- checkdepends = xorg-server-xvfb
- checkdepends = gtk3
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
makedepends = intltool
- makedepends = librsvg
+ makedepends = python-rjsmin
+ makedepends = gtk3
makedepends = python-gobject
- makedepends = slimit
+ makedepends = python-cairo
+ makedepends = librsvg
+ makedepends = xdg-utils
+ makedepends = libappindicator-gtk3
+ makedepends = python-pygame
+ makedepends = libnotify
depends = python-twisted
depends = python-pyopenssl
depends = python-rencode
- depends = python-xdg
+ depends = python-pyxdg
depends = python-six
depends = python-zope-interface
depends = python-chardet
@@ -35,23 +38,21 @@ pkgbase = deluge-git
depends = libtorrent-rasterbar
depends = desktop-file-utils
depends = hicolor-icon-theme
- optdepends = geoip: for displaying peer locations
+ optdepends = python-geoip: for displaying peer locations
optdepends = gtk3: for GTK user interface
optdepends = python-gobject: for GTK user interface and desktop popup notifications plugin
optdepends = python-cairo: for GTK user interface
optdepends = librsvg: for GTK user interface
+ optdepends = libappindicator-gtk3: for appindicator notifications
optdepends = python-dbus: for showing item location in filemanager
optdepends = python-pygame: for sound notifications plugin
optdepends = python-distro: for OS platform information
optdepends = libnotify: for dektop popup notifications plugin
provides = deluge
+ provides = deluge-gtk
conflicts = deluge
+ conflicts = deluge-gtk
source = git://deluge-torrent.org/deluge.git#branch=develop
- source = deluged.service
- source = deluge-web.service
sha256sums = SKIP
- sha256sums = 58a451bb6cf4fe6ff78a4fb71d51c5910340a2de032ff435c3c7365015ab538f
- sha256sums = 26e4d01003804afb197c570175d44ed4dddd443cc1b88ab2d0230ceacfac90c5
pkgname = deluge-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6c3e1e281a3d..8341dc63bdde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,68 +4,55 @@
# Contributor: Hugo Doria <hugo@archlinux.org>
pkgname=deluge-git
-pkgver=2.0.4.dev23.g2f1c008a2
+pkgver=2.1.1.dev61.g800111062
pkgrel=1
epoch=1
pkgdesc="A BitTorrent client with multiple user interfaces in a client/server model (git version, 'develop' branch)"
arch=('any')
url='https://deluge-torrent.org/'
license=('GPL3')
-depends=('python-twisted' 'python-pyopenssl' 'python-rencode' 'python-xdg'
+depends=('python-twisted' 'python-pyopenssl' 'python-rencode' 'python-pyxdg'
'python-six' 'python-zope-interface' 'python-chardet'
'python-setproctitle' 'python-pillow' 'python-pyasn1' 'python-mako'
'python-service-identity' 'python-setuptools' 'xdg-utils'
'libtorrent-rasterbar' 'desktop-file-utils' 'hicolor-icon-theme')
-optdepends=('geoip: for displaying peer locations'
+optdepends=('python-geoip: for displaying peer locations'
'gtk3: for GTK user interface'
'python-gobject: for GTK user interface and desktop popup notifications plugin'
'python-cairo: for GTK user interface'
'librsvg: for GTK user interface'
+ 'libappindicator-gtk3: for appindicator notifications'
'python-dbus: for showing item location in filemanager'
'python-pygame: for sound notifications plugin'
'python-distro: for OS platform information'
'libnotify: for dektop popup notifications plugin')
-makedepends=('git' 'intltool' 'librsvg' 'python-gobject' 'slimit')
-checkdepends=('python-pytest-twisted' 'python-pytest-cov' 'python-hypothesis'
- 'python-mock' 'python-cairo' 'xorg-server-xvfb' 'gtk3')
-provides=('deluge')
-conflicts=('deluge')
-BUILDENV=('!check')
-source=('git://deluge-torrent.org/deluge.git#branch=develop' # official repository
- #'git+https://github.com/deluge-torrent/deluge.git#branch=develop' # mirror
- 'deluged.service'
- 'deluge-web.service')
-sha256sums=('SKIP'
- '58a451bb6cf4fe6ff78a4fb71d51c5910340a2de032ff435c3c7365015ab538f'
- '26e4d01003804afb197c570175d44ed4dddd443cc1b88ab2d0230ceacfac90c5')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel'
+ 'intltool' 'python-rjsmin' 'gtk3' 'python-gobject' 'python-cairo' 'librsvg'
+ 'xdg-utils' 'libappindicator-gtk3' 'python-pygame' 'libnotify')
+provides=('deluge' 'deluge-gtk')
+conflicts=('deluge' 'deluge-gtk')
+source=('git://deluge-torrent.org/deluge.git#branch=develop')
+sha256sums=('SKIP')
pkgver() {
cd deluge
- local _internalver
- local _shorthash
- _internalver="$(python version.py)"
- _shorthash="$(git rev-parse --short HEAD)"
- printf '%s.g%s' "$_internalver" "$_shorthash"
+ printf '%s.g%s' "$(python version.py)" "$(git rev-parse --short HEAD)"
}
build() {
cd deluge
- python setup.py build
-}
-
-check() {
- cd deluge
- xvfb-run python setup.py test
+ python -m build --wheel --no-isolation
}
package() {
- cd deluge
- python setup.py install --prefix='/usr' --root="$pkgdir" --skip-build --optimize='1'
- install -D -m644 "${srcdir}/deluged.service" "${pkgdir}/usr/lib/systemd/system/deluged.service"
- install -D -m644 "${srcdir}/deluge-web.service" "${pkgdir}/usr/lib/systemd/system/deluge-web.service"
+ python -m installer --destdir="$pkgdir" deluge/dist/*.whl
+ install -D -m644 deluge/packaging/systemd/*.service -t "${pkgdir}/usr/lib/systemd/system"
+ install -D -m644 deluge/packaging/systemd/user/*.service -t "${pkgdir}/usr/lib/systemd/user"
+ install -D -m644 deluge/packaging/systemd/user.conf -t "${pkgdir}/usr/lib/systemd/system/deluged.service.d"
+ install -D -m644 deluge/packaging/systemd/user.conf -t "${pkgdir}/usr/lib/systemd/system/deluge-web.service.d"
ln -s deluge.png "${pkgdir}/usr/share/pixmaps/deluge-panel.png"
printf '%s\n' 'u deluge - "Deluge BitTorrent daemon" /srv/deluge' |
install -D -m644 /dev/stdin "${pkgdir}/usr/lib/sysusers.d/deluge.conf"
- printf '%s\n' 'd /srv/deluge 0775 deluge deluge' |
+ printf '%s\n' 'd /srv/deluge 0770 deluge deluge' |
install -D -m644 /dev/stdin "${pkgdir}/usr/lib/tmpfiles.d/deluge.conf"
}
diff --git a/deluge-web.service b/deluge-web.service
deleted file mode 100644
index 7a77b5c0ed0e..000000000000
--- a/deluge-web.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Deluge WebUI
-After=deluged.service
-
-[Service]
-User=deluge
-ExecStart=/usr/bin/deluge-web -d
-
-[Install]
-WantedBy=multi-user.target
diff --git a/deluged.service b/deluged.service
deleted file mode 100644
index 096b8f2f323b..000000000000
--- a/deluged.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Deluge Daemon
-After=network.target
-
-[Service]
-User=deluge
-ExecStart=/usr/bin/deluged -d
-UMask=0002
-
-[Install]
-WantedBy=multi-user.target