summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD89
3 files changed, 62 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5625427c58ff..c0e5525da2ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Sun Apr 9 18:25:14 UTC 2017
pkgbase = deluge-git
- pkgdesc = A bittorrent client written with python and pygtk - Git Version
- pkgver = 2.0.0.dev726
+ pkgdesc = A bittorrent client written with python and pygtk (git version, 'develop' branch)
+ pkgver = 2.0.0.dev979.ga727ee67b
pkgrel = 1
- url = http://deluge-torrent.org
+ url = http://deluge-torrent.org/
install = deluge.install
arch = any
license = GPL3
@@ -13,15 +15,16 @@ pkgbase = deluge-git
makedepends = python2-setuptools
makedepends = git
makedepends = python2-jsmin
+ makedepends = slimit2
depends = desktop-file-utils
depends = hicolor-icon-theme
- depends = libtorrent-rasterbar
depends = python2-service-identity
depends = python2-chardet
depends = python2-pyopenssl
depends = python2-xdg
depends = python2-twisted
depends = xdg-utils
+ depends = libtorrent-rasterbar-git=1.1.2.r0.ga42d4390c
optdepends = python2-pillow
optdepends = librsvg: needed for gtk ui
optdepends = pygtk: needed for gtk ui
@@ -31,12 +34,12 @@ pkgbase = deluge-git
provides = deluge
conflicts = deluge
conflicts = deluge-stable-git
- source = git+https://github.com/deluge-torrent/deluge.git#branch=develop
+ source = deluge-git::git://deluge-torrent.org/deluge.git#branch=develop
source = deluged.service
source = deluge-web.service
- md5sums = SKIP
- md5sums = 17f51ac9a90f0dc41a20291444a7489b
- md5sums = 2a73f62c04e8b147c731fbb50666e846
+ sha256sums = SKIP
+ sha256sums = 58a451bb6cf4fe6ff78a4fb71d51c5910340a2de032ff435c3c7365015ab538f
+ sha256sums = c3f2d6ad5bc9de5ffd9973d92badbe04a9ecf12c0c575e13d505a96add03275a
pkgname = deluge-git
diff --git a/.gitignore b/.gitignore
index 0f1e3d823c9d..10283ccd2791 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-deluge/
+deluge-git/
pkg/
src/
-*.pkg.tar
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index fae502a145d6..1213b27bfde5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,70 +1,79 @@
-# Maintainer: Jan "heftig" Steffens <jan.steffens@gmail.com>
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
# PKGBUILD based on extra\deluge's PKGBUILD, adapted for -git version by Berseker
pkgname=deluge-git
-pkgver=2.0.0.dev726
+pkgver=2.0.0.dev979.ga727ee67b
pkgrel=1
-pkgdesc="A bittorrent client written with python and pygtk - Git Version"
+pkgdesc="A bittorrent client written with python and pygtk (git version, 'develop' branch)"
arch=('any')
-url="http://deluge-torrent.org"
+url="http://deluge-torrent.org/"
license=('GPL3')
-conflicts=('deluge' 'deluge-stable-git')
provides=('deluge')
+conflicts=('deluge' 'deluge-stable-git')
install='deluge.install'
-
-depends=('desktop-file-utils'
- 'hicolor-icon-theme'
- 'libtorrent-rasterbar'
- 'python2-service-identity'
- 'python2-chardet'
- 'python2-pyopenssl'
- 'python2-xdg'
- 'python2-twisted'
- 'xdg-utils')
-
-makedepends=('intltool'
- 'librsvg'
- 'pygtk'
- 'python2-mako'
- 'python2-setuptools'
- 'git'
- 'python2-jsmin')
-
+depends=( # binary repositories:
+ 'desktop-file-utils'
+ 'hicolor-icon-theme'
+ #'libtorrent-rasterbar=1.1.2'
+ 'python2-service-identity'
+ 'python2-chardet'
+ 'python2-pyopenssl'
+ 'python2-xdg'
+ 'python2-twisted'
+ 'xdg-utils'
+ # AUR:
+ 'libtorrent-rasterbar-git=1.1.2.r0.ga42d4390c')
+makedepends=( # binary repositories:
+ 'intltool'
+ 'librsvg'
+ 'pygtk'
+ 'python2-mako'
+ 'python2-setuptools'
+ 'git'
+ # AUR:
+ 'python2-jsmin'
+ 'slimit2')
optdepends=('python2-pillow'
'librsvg: needed for gtk ui'
'pygtk: needed for gtk ui'
'python2-mako: needed for web ui'
'python2-notify: libnotify notifications'
'geoip: display peer locations')
-
-source=("git+https://github.com/deluge-torrent/deluge.git#branch=develop"
- 'deluged.service' 'deluge-web.service')
-
-md5sums=('SKIP'
- '17f51ac9a90f0dc41a20291444a7489b'
- '2a73f62c04e8b147c731fbb50666e846')
-
-pkgver() {
- cd "$srcdir/deluge"
- #git log -1 --format="%cd" --date=short | tr -d '-'
- python2 version.py
-}
+source=("$pkgname"::"git://deluge-torrent.org/deluge.git#branch=develop" # official repository
+ #"$pkgname"::"git+https://github.com/deluge-torrent/deluge.git#branch=develop" # mirror
+ 'deluged.service'
+ 'deluge-web.service')
+sha256sums=('SKIP'
+ '58a451bb6cf4fe6ff78a4fb71d51c5910340a2de032ff435c3c7365015ab538f'
+ 'c3f2d6ad5bc9de5ffd9973d92badbe04a9ecf12c0c575e13d505a96add03275a')
prepare() {
- cd "$srcdir/deluge/deluge/ui/data/icons"
+ cd "$pkgname/deluge/ui/data/icons"
ln -sf hicolor/scalable scalable
}
+pkgver() {
+ cd "$pkgname"
+
+ local _internalver="$(python2 version.py)"
+ local _shorthash="$(git rev-parse --short HEAD)"
+ printf "%s.g%s" "$_internalver" "$_shorthash"
+
+ # alternative
+ #git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^deluge\.//;s/dev[[:digit:]]*\.//'
+}
+
build() {
- cd "$srcdir/deluge"
+ cd "$pkgname"
python2 setup.py build
python2 minify_web_js.py deluge/ui/web/js/deluge-all
}
package() {
- cd "$srcdir/deluge"
+ cd "$pkgname"
python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
install -d "$pkgdir/srv"