summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
-rw-r--r--bug-egg.patch16
-rw-r--r--bug-gtk.patch31
4 files changed, 9 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c2796d3e082..9e005e64b869 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
pkgbase = deluge-labelplus
pkgdesc = LabelPlus is a plugin for Deluge for labeling torrent, with much more functionalities that the builtin Labels.
- pkgver = 0.3.2.4
- pkgrel = 3
+ pkgver = 0.3.2.5
+ pkgrel = 1
url = https://github.com/laur89/deluge-labelplus
arch = any
license = GPL3
makedepends = python-setuptools
depends = deluge
- source = https://github.com/laur89/deluge-labelplus/archive/refs/tags/0.3.2.4.tar.gz
- source = bug-gtk.patch
- source = bug-egg.patch
- sha256sums = 8122daab527c02987ed602b9687fd46b306f60f9e0f044a2ed2bb1a342178e07
- sha256sums = 9d3700d54c579dc20f766dcc6a2702bbfc2c98992a216a16053c074bc38f6d0e
- sha256sums = b5fd58c6ba2ca0765094763695d919fe1bf861e361d29d0ba8a3ec7773a47069
+ source = https://github.com/laur89/deluge-labelplus/archive/refs/tags/0.3.2.5.tar.gz
+ sha256sums = 63c22bb90a15ffe779378ffb6e73280fc88a26c6b9a1515013d652a58cf5dd42
pkgname = deluge-labelplus
diff --git a/PKGBUILD b/PKGBUILD
index de9c849b546a..dd6baf7b2a28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: getzze <getzze@gmail.com>
pkgname=deluge-labelplus
-pkgver=0.3.2.4
-pkgrel=3
+pkgver=0.3.2.5
+pkgrel=1
pkgdesc="LabelPlus is a plugin for Deluge for labeling torrent, with much more functionalities that the builtin Labels."
arch=('any')
## Set to fork until included upstream
@@ -12,19 +12,9 @@ url="https://github.com/laur89/deluge-labelplus"
license=(GPL3)
depends=('deluge')
makedepends=('python-setuptools')
-#source=($url/archive/v$pkgver.tar.gz)
-source=("$url/archive/refs/tags/$pkgver.tar.gz"
- bug-gtk.patch
- bug-egg.patch)
-sha256sums=('8122daab527c02987ed602b9687fd46b306f60f9e0f044a2ed2bb1a342178e07'
- '9d3700d54c579dc20f766dcc6a2702bbfc2c98992a216a16053c074bc38f6d0e'
- 'b5fd58c6ba2ca0765094763695d919fe1bf861e361d29d0ba8a3ec7773a47069')
+source=("$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('63c22bb90a15ffe779378ffb6e73280fc88a26c6b9a1515013d652a58cf5dd42')
-prepare() {
- cd "${srcdir}/$pkgname-$pkgver"
- patch -p0 -i "${srcdir}/bug-egg.patch"
- patch -p0 -i "${srcdir}/bug-gtk.patch"
-}
build() {
cd "${srcdir}/$pkgname-$pkgver"
@@ -34,5 +24,5 @@ build() {
package() {
cd "${srcdir}/$pkgname-$pkgver"/dist
local _pyver=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
- install -Dm644 "LabelPlus-$pkgver-py${_pyver}.egg" "${pkgdir}/usr/lib/python${_pyver}/site-packages/deluge/plugins/LabelPlus-$pkgver-py${_pyver}.egg"
+ install -Dm644 "LabelPlus-$pkgver.egg" "${pkgdir}/usr/lib/python${_pyver}/site-packages/deluge/plugins/LabelPlus-$pkgver-py${_pyver}.egg"
}
diff --git a/bug-egg.patch b/bug-egg.patch
deleted file mode 100644
index 853446a27fd6..000000000000
--- a/bug-egg.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- setup.py 2022-10-07 18:10:29.000000000 +0100
-+++ setup2.py 2022-10-19 12:48:33.437435609 +0100
-@@ -74,13 +75,3 @@
- )
-
- # original setup-generated filename: LabelPlus-0.3.2.4-py3.9.egg
--
--# rename generated.egg to exclude the py version from filename:
--list_of_eggs = glob.glob('./dist/*.egg')
--if list_of_eggs:
-- newest_egg = max(list_of_eggs, key=os.path.getmtime)
--
-- os.rename(
-- newest_egg,
-- os.path.join('dist', __plugin_name__ + '-' + version + '.egg')
-- )
diff --git a/bug-gtk.patch b/bug-gtk.patch
deleted file mode 100644
index cb3b8cc004de..000000000000
--- a/bug-gtk.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- labelplus/gtkui/common/gtklib/dnd.py 2022-10-07 18:10:29.000000000 +0100
-+++ labelplus/gtkui/common/gtklib/dnd-new.py 2022-10-27 12:49:17.865003272 +0100
-@@ -242,9 +242,7 @@
-
- def _do_drag_button_press(self, widget, event):
-
-- _, x, y, _ = widget.get_bin_window().get_device_position(event.get_source_device())
-- pos = widget.convert_bin_window_to_tree_coords(x, y)
-- if pos[1] < 0:
-+ if event.y < 0:
- return False
-
- log.debug("%s Do button-press at b(%d, %d), Button: %s",
-@@ -655,14 +653,9 @@
- if src and not same:
-
- targets = src.drag_source_get_target_list() or Gtk.TargetList.new()
-- for t in targets:
--
-- if t[0] == target.name:
--
-- if t[1] & Gtk.TargetFlags.SAME_WIDGET:
-- target = None
--
-- break
-+ res, info = targets.find(atom)
-+ if res and info & Gtk.TargetFlags.SAME_WIDGET:
-+ target = None
-
- return target
-