summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f844f7255b0f..d542ad0fc290 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = dep-bin
pkgdesc = Go dependency management tool
pkgver = 0.5.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/golang/dep
arch = any
license = BSD
provides = dep
conflicts = dep
+ source = LICENSE
source = https://github.com/golang/dep/releases/download/v0.5.4/dep-linux-amd64
+ sha256sums = 69c47f09a7aec01c59ff1bdc346406d36e84df11461fb2bed92b0d185a7a2ccb
sha256sums = 40a78c13753f482208d3f4bea51244ca60a914341050c588dad1f00b1acc116c
pkgname = dep-bin
diff --git a/PKGBUILD b/PKGBUILD
index edbbfce6e7b7..84d007136585 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Moses Narrow <moe_narrow@use.startmail.com>
+# Maintainer: Chris Werner Rau < aur [ at ] cwrau [ dot ] io >
# contributer: Alif Rachmawadi <arch@subosito.com>
pkgname=dep-bin
pkgver=0.5.4
-pkgrel=1
+pkgrel=2
pkgdesc="Go dependency management tool"
pkgoption1="dep-linux-amd64"
pkgoption2="dep-linux-arm64"
@@ -11,8 +12,8 @@ url="https://github.com/golang/dep"
license=('BSD')
conflicts=('dep')
provides=('dep')
-source=("LICENSE")
#detect architecture & adjust source & checksums accordingly
+sha256sums=('69c47f09a7aec01c59ff1bdc346406d36e84df11461fb2bed92b0d185a7a2ccb')
case "$CARCH" in
arm*) _pkgarch="$pkgoption2"
sha256sums+=('9dbf1612044598cbb195933213eb3c4bab5d4ada0ce5b90a91241c4431b1783a')
@@ -24,9 +25,9 @@ case "$CARCH" in
sha256sums+=('40a78c13753f482208d3f4bea51244ca60a914341050c588dad1f00b1acc116c')
;;
esac
-source=("${url}/releases/download/v${pkgver}/$_pkgarch")
+source=("LICENSE" "${url}/releases/download/v${pkgver}/$_pkgarch")
package() {
- install -Dm755 ../dep-linux-a* ${pkgdir}/usr/bin/dep
- install -Dm644 ../LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm755 dep-linux-a* ${pkgdir}/usr/bin/dep
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}