summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
-rw-r--r--devilspie2-0.43-lua-5.4.patch13
3 files changed, 11 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44c6eb7e27e0..65e8a1c2db5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = devilspie2
pkgdesc = A window matching utility, allowing the user to perform scripted actions on windows as they are created.
- pkgver = 0.43
+ pkgver = 0.44
pkgrel = 1
url = http://www.nongnu.org/devilspie2/
arch = i686
@@ -9,13 +9,10 @@ pkgbase = devilspie2
depends = lua>=5.1
depends = gtk3
depends = libwnck3
- source = http://download.savannah.nongnu.org/releases/devilspie2/devilspie2_0.43-src.tar.gz
- source = http://download.savannah.nongnu.org/releases/devilspie2/devilspie2_0.43-src.tar.gz.asc
- source = devilspie2-0.43-lua-5.4.patch
- validpgpkeys = DB306E4B10FFD98EF4DB55D7194B631AB2DA2888
- md5sums = 26eed0b5b4af5c7e13c551eceaeab832
- md5sums = SKIP
- md5sums = 8fd96127706934b138af50aaa2da0664
+ source = http://download.savannah.nongnu.org/releases/devilspie2/devilspie2-0.44.tar.xz
+ source = http://download.savannah.nongnu.org/releases/devilspie2/devilspie2-0.44.tar.xz.sig
+ validpgpkeys = A523530DD1E9FDDFAD3D5FCAA9B57A926EF302F5
+ sha256sums = 0a9f1eadd2b22a318163e4180065d495221ba1a43ad2021ea6866cd118042640
+ sha256sums = SKIP
pkgname = devilspie2
-
diff --git a/PKGBUILD b/PKGBUILD
index 89ed777fe9f3..dfa1f01b9518 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,15 @@
pkgname=devilspie2
-pkgver=0.43
+pkgver=0.44
pkgrel=1
pkgdesc="A window matching utility, allowing the user to perform scripted actions on windows as they are created."
arch=('i686' 'x86_64')
url="http://www.nongnu.org/$pkgname/"
license=('GPL3')
depends=('lua>=5.1' 'gtk3' 'libwnck3')
-source=("http://download.savannah.nongnu.org/releases/$pkgname/${pkgname}_$pkgver-src.tar.gz"{,.asc}
- "$pkgname-0.43-lua-5.4.patch")
-md5sums=('26eed0b5b4af5c7e13c551eceaeab832'
- 'SKIP'
- '8fd96127706934b138af50aaa2da0664')
-validpgpkeys=('DB306E4B10FFD98EF4DB55D7194B631AB2DA2888') # Andreas Rönnquist <gusnan@gusnan.se>
-
-prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 -i "$srcdir/$pkgname-0.43-lua-5.4.patch"
-}
+source=("http://download.savannah.nongnu.org/releases/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
+sha256sums=('0a9f1eadd2b22a318163e4180065d495221ba1a43ad2021ea6866cd118042640'
+ 'SKIP')
+validpgpkeys=('A523530DD1E9FDDFAD3D5FCAA9B57A926EF302F5') # Darren Salt <devspam@moreofthesa.me.uk>
build() {
cd "$pkgname-$pkgver"
diff --git a/devilspie2-0.43-lua-5.4.patch b/devilspie2-0.43-lua-5.4.patch
deleted file mode 100644
index 8cbec6bafadf..000000000000
--- a/devilspie2-0.43-lua-5.4.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -ur -Nur devilspie2-0.43.orig/src/script_functions.c devilspie2-0.43/src/script_functions.c
---- devilspie2-0.43.orig/src/script_functions.c 2017-09-26 15:03:36.000000000 +0200
-+++ devilspie2-0.43/src/script_functions.c 2020-06-30 15:29:15.024643740 +0200
-@@ -470,8 +470,7 @@
- lua_call(lua, 1, 1);
- s = lua_tostring(lua, -1); /* get result */
- if (s == NULL)
-- return luaL_error(lua, LUA_QL("tostring") " must return a string to "
-- LUA_QL("print"));
-+ return luaL_error(lua, "'tostring' must return a string to 'print'");
- if (i > 1) {
- if (devilspie2_debug) fputs("\t", stdout);
- }