summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
-rw-r--r--fix-dex-version.patch11
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a30073f9de2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = dex-protecto-git
+ pkgdesc = Program to generate and execute DesktopEntry files of type Application, protecto's fork
+ pkgver = r84.bd85b78
+ pkgrel = 1
+ url = https://github.com/protecto/dex
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = python-sphinx
+ depends = python
+ provides = dex
+ conflicts = dex
+ conflicts = dex-git
+ source = git+https://github.com/protecto/dex.git
+ source = fix-dex-version.patch
+ md5sums = SKIP
+ md5sums = f2be2e9ea5f6317f89bd07af1cfe5565
+
+pkgname = dex-protecto-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2510c2a8dc5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Krystian ChachuĊ‚a <krystiancha@gmail.com>
+
+pkgname=dex-protecto-git
+pkgver=r84.bd85b78
+pkgrel=1
+
+pkgdesc="Program to generate and execute DesktopEntry files of type Application, protecto's fork"
+url='https://github.com/protecto/dex'
+arch=('any')
+license=('GPL2')
+
+depends=('python')
+makedepends=('git' 'python-sphinx')
+
+provides=('dex')
+conflicts=('dex' 'dex-git')
+
+source=("git+https://github.com/protecto/dex.git"
+ fix-dex-version.patch)
+
+md5sums=('SKIP'
+ 'f2be2e9ea5f6317f89bd07af1cfe5565')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-protecto-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd dex
+ patch dex <"$srcdir"/fix-dex-version.patch
+}
+
+package() {
+ cd dex
+ make install PREFIX=/usr MANPREFIX=/usr/share/man DESTDIR="$pkgdir"
+ rm "$pkgdir/usr/share/doc/dex/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/fix-dex-version.patch b/fix-dex-version.patch
new file mode 100644
index 000000000000..078cf213538b
--- /dev/null
+++ b/fix-dex-version.patch
@@ -0,0 +1,11 @@
+--- /usr/bin/dex 2017-06-19 02:43:55.415177617 +0200
++++ dex.new 2017-06-19 02:46:55.251836314 +0200
+@@ -35,7 +35,7 @@
+ import subprocess
+ import sys
+
+-__version__ = "0.8.0"
++__version__ = "protecto-git"
+
+
+ # DesktopEntry exceptions