summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE4
-rw-r--r--PKGBUILD35
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d06ac73b9d3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dextools
+ pkgdesc = Miscellaenous DEX (Dalvik Executable) tools. Including dexrehash which displays/recomputes checksum.
+ pkgver = 20130513
+ pkgrel = 1
+ url = https://github.com/cryptax/dextools
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = perl-digest-adler32
+ options = !strip
+ source = LICENSE
+ md5sums = cc283015f95abdc7db365416df806c20
+
+pkgname = dextools
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ff66b9cee9fc
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,4 @@
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
+Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
+Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80f3d492f641
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: dobo <dobo90_at_gmail.com>
+
+pkgname=dextools
+pkgver=20130513
+pkgrel=1
+pkgdesc='Miscellaenous DEX (Dalvik Executable) tools. Including dexrehash which displays/recomputes checksum.'
+arch=(any)
+url='https://github.com/cryptax/dextools'
+license=(BSD)
+depends=(perl-digest-adler32)
+makedepends=(git)
+source=(LICENSE)
+md5sums=(cc283015f95abdc7db365416df806c20)
+options=(!strip)
+
+__gitroot="https://github.com/cryptax/dextools"
+__gitname="dextools"
+
+package() {
+ cd ${srcdir}
+
+ # Git checkout
+ if [ -d ${srcdir}/${__gitname} ] ; then
+ msg "Git checkout: Updating existing tree"
+ cd ${__gitname} && git checkout
+ msg "Git checkout: Tree has been updated"
+ else
+ msg "Git checkout: Retrieving sources"
+ git clone ${__gitroot} && cd ${__gitname} && git checkout
+ fi
+ msg "Checkout completed"
+
+ install -D -m 755 dexrehash.pl ${pkgdir}/usr/bin/dexrehash
+ install -D -m 644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}