summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD31
-rw-r--r--qt6.patch66
3 files changed, 89 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1318c99866a..597c55935817 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = dg100ctl
pkgdesc = Program to configure the GlobalSat DG-100 GPS data logger
pkgver = 0.1
- pkgrel = 2
- url = http://xpg.dk/projects/dg100ctl
+ pkgrel = 3
+ url = http://launchpad.net/dg100ctl
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
- depends = qt4
+ depends = qt6-base
source = http://launchpad.net/dg100ctl/trunk/0.1/+download/dg100ctl-0.1.tar.bz2
+ source = qt6.patch
md5sums = 07008d7366148c2e1811ca20f8ccd9c4
+ md5sums = 81195bd97ed5d549636e2a463c414487
pkgname = dg100ctl
-
diff --git a/PKGBUILD b/PKGBUILD
index a47b950140dc..c0135fa5d3d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,31 @@
-# Maintainer: Vincent Prelat <prelatv [at] gmail.com>
-
pkgname=dg100ctl
pkgver=0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Program to configure the GlobalSat DG-100 GPS data logger"
-url="http://xpg.dk/projects/dg100ctl"
+url="http://launchpad.net/$pkgname"
arch=('i686' 'x86_64')
license=('GPL')
-depends=('qt4')
+depends=('qt6-base')
makedepends=('cmake')
-source=(http://launchpad.net/$pkgname/trunk/$pkgver/+download/$pkgname-$pkgver.tar.bz2)
-md5sums=('07008d7366148c2e1811ca20f8ccd9c4')
+source=(http://launchpad.net/$pkgname/trunk/$pkgver/+download/$pkgname-$pkgver.tar.bz2 qt6.patch)
+md5sums=('07008d7366148c2e1811ca20f8ccd9c4'
+ '81195bd97ed5d549636e2a463c414487')
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch --forward --strip=2 --input=${srcdir}/qt6.patch
+}
build() {
- cd $startdir/src/$pkgname-$pkgver
-
+ cd "$pkgname-$pkgver"
mkdir build
cd build
- cmake -D QT_QMAKE_EXECUTABLE=qmake4 -D CMAKE_INSTALL_PREFIX=/usr .. || return 1
- make || return 1
- make DESTDIR=$startdir/pkg install || return 1
-
+ cmake -D CMAKE_INSTALL_PREFIX=/usr ..
+ make
}
+package() {
+ cd "$pkgname-$pkgver"
+ cd build
+ make DESTDIR="$pkgdir" install
+} \ No newline at end of file
diff --git a/qt6.patch b/qt6.patch
new file mode 100644
index 000000000000..1ecb812942f3
--- /dev/null
+++ b/qt6.patch
@@ -0,0 +1,66 @@
+diff --unified --recursive package.ori/dg100ctl-0.1/qt-dg100ctl/CMakeLists.txt package.new/dg100ctl-0.1/qt-dg100ctl/CMakeLists.txt
+--- package.ori/dg100ctl-0.1/qt-dg100ctl/CMakeLists.txt 2009-01-14 21:34:57.000000000 +0100
++++ package.new/dg100ctl-0.1/qt-dg100ctl/CMakeLists.txt 2023-12-06 11:57:15.812853462 +0100
+@@ -1,6 +1,8 @@
+-FIND_PACKAGE(Qt4)
+-INCLUDE(${QT_USE_FILE})
+-INCLUDE(UseQt4)
++set(CMAKE_AUTOUIC ON)
++set(CMAKE_AUTOMOC ON)
++FIND_PACKAGE(Qt6 COMPONENTS Widgets)
++#INCLUDE(${QT_USE_FILE})
++#INCLUDE(UseQt4)
+
+ include_directories(
+ ${DG100CTL_SOURCE_DIR}/shared
+@@ -14,13 +16,13 @@
+
+ add_definitions(${QT_DEFINITIONS})
+
+-qt4_wrap_ui(qt-dg100ctl-ui
+- ConfigurationDialog.ui
+- DG100Dialog.ui)
+-
+-qt4_wrap_cpp(qt-dg100ctl-moc
+- ConfigurationDialog.hpp
+- DG100Dialog.hpp)
++#qt4_wrap_ui(qt-dg100ctl-ui
++# ConfigurationDialog.ui
++# DG100Dialog.ui)
++
++#qt4_wrap_cpp(qt-dg100ctl-moc
++# ConfigurationDialog.hpp
++# DG100Dialog.hpp)
+
+ #qt4_add_translation( qt-dg100ctl-qm
+ # qt-dg100ctl_dk.ts )
+@@ -39,7 +41,7 @@
+ #add_custom_target( qt-dg100ctl-translations DEPENDS ${qt-dg100ctl-qm} )
+ #add_dependencies( qt-dg100ctl qt-dg100ctl-translations )
+
+-target_link_libraries(qt-dg100ctl dg100-comm ${QT_LIBRARIES})
++target_link_libraries(qt-dg100ctl dg100-comm Qt${qt_version}::Widgets)
+ install(TARGETS qt-dg100ctl
+ RUNTIME DESTINATION bin)
+ install(FILES qt-dg100ctl.desktop
+diff --unified --recursive package.ori/dg100ctl-0.1/qt-dg100ctl/DG100Dialog.cpp package.new/dg100ctl-0.1/qt-dg100ctl/DG100Dialog.cpp
+--- package.ori/dg100ctl-0.1/qt-dg100ctl/DG100Dialog.cpp 2009-01-14 21:34:57.000000000 +0100
++++ package.new/dg100ctl-0.1/qt-dg100ctl/DG100Dialog.cpp 2023-12-06 11:57:46.549215836 +0100
+@@ -45,7 +45,7 @@
+ void
+ DG100Dialog::getSettings()
+ {
+- QByteArray dev = this->deviceName.toAscii();
++ QByteArray dev = this->deviceName.toLatin1();
+ const char *deviceName = dev.constData();
+
+ statusLabel->setText( tr("Retrieving settings from device") );
+@@ -102,7 +102,7 @@
+ void
+ DG100Dialog::setSettings()
+ {
+- QByteArray dev = this->deviceName.toAscii();
++ QByteArray dev = this->deviceName.toLatin1();
+ const char *deviceName = dev.constData();
+
+ statusLabel->setText( tr("Saving settings to device") );