summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD14
3 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55d0d18f71cf..335801091477 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Nov 13 13:36:24 UTC 2016
pkgbase = dhtfs
pkgdesc = Tagging based filesystem, providing dynamic directory hierarchies based on tags associated with files
pkgver = 0.3.0
pkgrel = 3
- url = http://code.google.com/p/dhtfs/
+ url = https://github.com/mayuresh/dhtfs
arch = any
- license = custom
+ license = BSD3
depends = python2
depends = python2-fuse
- source = http://dhtfs.googlecode.com/files/dhtfs-0.3.0.tar.gz
- md5sums = 9e2c16ef88f925453aac5935354f5a35
+ source = git://github.com/mayuresh/dhtfs#commit=f28fb55
+ md5sums = SKIP
pkgname = dhtfs
diff --git a/.gitignore b/.gitignore
index 3a3642b6f6ff..4ba4d315a49f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
-*/src
-*/pkg
+dhtfs/
+src/
+pkg/
*.gz
*.xz
*.bz2
@@ -10,5 +11,5 @@
*.txt
*.log
*.scm
-*/*.pkg
-*/*.asc
+*.pkg
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
index 7587f437d1d0..4aec102975d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,19 @@ pkgver=0.3.0
pkgrel=3
pkgdesc="Tagging based filesystem, providing dynamic directory hierarchies based on tags associated with files"
arch=(any)
-url="http://code.google.com/p/dhtfs/"
-license=(custom)
+#url="http://code.google.com/p/dhtfs/"
+#Repo of author
+url=https://github.com/mayuresh/dhtfs
+license=(BSD3)
depends=('python2' 'python2-fuse')
-source=("http://dhtfs.googlecode.com/files/$pkgname-$pkgver.tar.gz")
-md5sums=('9e2c16ef88f925453aac5935354f5a35')
+#source=("http://dhtfs.googlecode.com/files/$pkgname-$pkgver.tar.gz")
+source=("git://github.com/mayuresh/dhtfs#commit=f28fb55")
+md5sums=('SKIP')
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ #cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
python2 setup.py install --prefix=/usr/ --root=$pkgdir
install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE