summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87d3fe5b07f0..b4bde19b855b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = dialect-git
pkgrel = 1
url = https://apps.gnome.org/Dialect
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
checkdepends = appstream-glib
makedepends = blueprint-compiler
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index f3ede6613663..6902a42d0ac4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgrel=1
pkgdesc="A translation app for GNOME."
arch=('any')
url="https://apps.gnome.org/Dialect"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('dbus-python' 'gst-python' 'libadwaita' 'libsoup3' 'python-gobject' 'python-gtts')
makedepends=('blueprint-compiler' 'git' 'gobject-introspection' 'meson')
checkdepends=('appstream-glib')
@@ -18,14 +18,14 @@ sha256sums=('SKIP'
'SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
git submodule init
- git config submodule.po.url $srcdir/po
+ git config submodule.po.url "$srcdir/po"
git -c protocol.file.allow=always submodule update
}