summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f02e7f5552d6..c65ecbec9bff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = diaspora-mysql
pkgdesc = A distributed privacy aware social network (MySQL)
- pkgver = 0.7.18.1
+ pkgver = 0.7.18.2
pkgrel = 1
url = https://diasporafoundation.org
install = diaspora.install
@@ -8,8 +8,8 @@ pkgbase = diaspora-mysql
arch = x86_64
license = AGPL3
makedepends = nodejs
- depends = ruby2.6
- depends = ruby2.6-bundler
+ makedepends = yarn
+ depends = ruby2.7
depends = redis
depends = imagemagick
depends = libxslt
@@ -27,13 +27,13 @@ pkgbase = diaspora-mysql
backup = etc/webapps/diaspora/diaspora.toml
backup = etc/webapps/diaspora/database.yml
backup = etc/webapps/diaspora/secret_token.rb
- source = diaspora-0.7.18.1.tar.gz::https://github.com/diaspora/diaspora/archive/v0.7.18.1.tar.gz
+ source = diaspora-0.7.18.2.tar.gz::https://github.com/diaspora/diaspora/archive/v0.7.18.2.tar.gz
source = diaspora.install
source = diaspora.service
source = diaspora.tmpfiles.d.conf
source = diaspora.bashrc
source = diaspora.bash_profile
- sha256sums = 9dba7fc8ec261bc00c4f5d45af38e3c7aa9e44204dce3b2b79feeed3a120d148
+ sha256sums = 0b5828aa45af2361bfda4cd0f1e97070c322d90f1d16416bae2cba2418af9930
sha256sums = aae126c4b1bcba6265d3d925dc3845bb034defa5606385c22dfb053111b57685
sha256sums = 2ac3ef6c4f0396b7738b18d07c56f57e0db5e5e194bf8b07ffd6ad790dd92e17
sha256sums = 7128024976c95d511d8995c472907fe0b8c36fe5b45fef57fc053e3fadcae408
diff --git a/PKGBUILD b/PKGBUILD
index 839cd6fabf7c..8b56e97afe0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Jonne Haß <me@jhass.eu>
pkgname='diaspora-mysql'
-pkgver=0.7.18.1
+pkgver=0.7.18.2
pkgrel=1
pkgdesc="A distributed privacy aware social network (MySQL)"
arch=('i686' 'x86_64')
url="https://diasporafoundation.org"
license=('AGPL3')
-depends=('ruby2.6' 'ruby2.6-bundler' 'redis' 'imagemagick' 'libxslt' 'net-tools' 'gsfonts' 'libtirpc' 'libmariadbclient')
+depends=('ruby2.7' 'redis' 'imagemagick' 'libxslt' 'net-tools' 'gsfonts' 'libtirpc' 'libmariadbclient')
optdepends=('jemalloc: lower memory consumption' 'mariadb: Database server')
-makedepends=('nodejs' )
+makedepends=('nodejs' 'yarn' )
conflicts=('diaspora-postgresql' 'diaspora-mysql-git' 'diaspora-postgresql-git')
options=(!strip)
backup=("etc/webapps/diaspora/diaspora.yml"
@@ -46,10 +46,10 @@ _reset_ruby() {
}
build() {
- _bundle=bundle-2.6
- _ruby=ruby-2.6
- _rake=rake-2.6
- _gem=gem-2.6
+ _bundle=bundle-2.7
+ _ruby=ruby-2.7
+ _rake=rake-2.7
+ _gem=gem-2.7
_builddir=$srcdir/build
_reset_ruby
@@ -57,14 +57,15 @@ build() {
msg "Setup build directory"
rm -rf $_builddir
mkdir -p $_builddir
- cp -Rf $srcdir/diaspora-0.7.18.1/{bin,app,config,db,public,lib,script,vendor,config.ru,Gemfile,Gemfile.lock,Rakefile} $_builddir
+ cp -Rf $srcdir/diaspora-0.7.18.2/{bin,app,config,db,public,lib,script,vendor,config.ru,Gemfile,Gemfile.lock,Rakefile} $_builddir
+
cd $_builddir
msg "Bundle dependencies"
echo "gem: --no-rdoc --no-ri --no-user-install" > $_builddir/.gemrc
export GEM_HOME="$_builddir/vendor/bundle"
- HOME=$_builddir $_gem install bundler -v 1.17.3
+ HOME=$_builddir $_gem install bundler -v 2.1.4
HOME=$_builddir $_bundle config --local path vendor/bundle
HOME=$_builddir $_bundle config --local frozen 1
HOME=$_builddir $_bundle config --local disable_shared_gems true
@@ -94,8 +95,8 @@ build() {
}
package() {
- _bundle=bundle-2.6
- _ruby=ruby-2.6
+ _bundle=bundle-2.7
+ _ruby=ruby-2.7
_builddir=$srcdir/build
msg "Copy contents to package directory"
@@ -137,7 +138,7 @@ package() {
ln -sf /var/log/diaspora $pkgdir/usr/share/webapps/diaspora/log
}
-sha256sums=('9dba7fc8ec261bc00c4f5d45af38e3c7aa9e44204dce3b2b79feeed3a120d148'
+sha256sums=('0b5828aa45af2361bfda4cd0f1e97070c322d90f1d16416bae2cba2418af9930'
'aae126c4b1bcba6265d3d925dc3845bb034defa5606385c22dfb053111b57685'
'2ac3ef6c4f0396b7738b18d07c56f57e0db5e5e194bf8b07ffd6ad790dd92e17'
'7128024976c95d511d8995c472907fe0b8c36fe5b45fef57fc053e3fadcae408'