summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 424515a7c482..b2c95c064cf9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = dibuja
- pkgdesc = Gtk based basic paint program like classic MS Paint or Paintbrush for Mac but for Linux
- pkgver = 0.21.12
+ pkgdesc = Gtk based basic paint program like classic MS Paint or Paintbrush for Mac, for Linux
+ pkgver = 0.24.0
pkgrel = 1
url = https://launchpad.net/dibuja
arch = x86_64
license = GPL3
- makedepends = automake-1.15
+ makedepends = automake
depends = gtk2
depends = gegl
- source = https://launchpad.net/dibuja/trunk/0.21.12/+download/dibuja-0.21.12.tar.gz
- sha256sums = c4b4f533a8e4628862e0fe4d2ac3e4d4134befc417727e96a4eab988596abf5a
+ depends = babl
+ depends = libgexiv2
+ source = https://launchpad.net/dibuja/trunk/0.24.0/+download/dibuja-0.24.0.tar.gz
+ sha256sums = a9c98b386667287e330c8b8572001ffbf1be10a639adc05ec7b67bbdffc4731b
pkgname = dibuja
-
diff --git a/PKGBUILD b/PKGBUILD
index 86a68e84285f..381eb30b9690 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
-# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Maintainer: Matthew Sexton <matthew@asylumtech.com>
+# Contributor: Frederic Bezies <fredbezies at gmail dot com>
# Contributor: Daniel Milde <daniel at milde dot cz>
pkgname=dibuja
-pkgver=0.21.12
+pkgver=0.24.0
pkgrel=1
-pkgdesc="Gtk based basic paint program like classic MS Paint or Paintbrush for Mac but for Linux"
+pkgdesc="Gtk based basic paint program like classic MS Paint or Paintbrush for Mac, for Linux"
+arch=("x86_64")
url="https://launchpad.net/dibuja"
-makedepends=('automake-1.15')
-source=("https://launchpad.net/dibuja/trunk/$pkgver/+download/dibuja-$pkgver.tar.gz")
license=("GPL3")
-arch=("x86_64")
-depends=(gtk2 gegl)
+depends=('gtk2' 'gegl' 'babl' 'libgexiv2')
+makedepends=('automake')
+source=("$url/trunk/$pkgver/+download/$pkgname-$pkgver.tar.gz")
+sha256sums=('a9c98b386667287e330c8b8572001ffbf1be10a639adc05ec7b67bbdffc4731b')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
autoconf
- ./configure --prefix=/usr --libdir=/usr/lib --with-gegl-0.4
+ ./configure --prefix=/usr --libdir=/usr/lib
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
-sha256sums=('c4b4f533a8e4628862e0fe4d2ac3e4d4134befc417727e96a4eab988596abf5a')