summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--CHANGELOG.md13
-rw-r--r--PKGBUILD20
3 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1be74b7daea7..6749eddcf006 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dirsearch-git
pkgdesc = Web path scanner/fuzzer, written in Python
- pkgver = 0.4.2.r56.b83e68c
+ pkgver = 0.4.2.r298.ec05dec
pkgrel = 1
epoch = 1
url = https://github.com/maurosoria/dirsearch
@@ -18,7 +18,6 @@ pkgbase = dirsearch-git
depends = python-cffi
provides = dirsearch
conflicts = dirsearch
- backup = etc/dirsearch/default.conf
source = git+https://github.com/maurosoria/dirsearch.git
sha256sums = SKIP
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 5ff13665dfb2..dc3b322ec1ae 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,7 +1,15 @@
# Changelog
-## [0.4.3]
-- Automatically detect the URI scheme (http or https) if no scheme is provided
+## Developing
+- Automatically detect the URI scheme (`http` or `https`) if no scheme is provided
+- SQLite report format
+- Option to overwrite unwanted extensions with selected extensions
+- Option to view redirects history when following redirects
+- Option to crawl web paths in the responses
+- HTTP traffic is saved inside log file
+- Capability to save progress and resume later
+- Support client certificate
+- Ability to limit the maximum size of the log file (bytes)
## [0.4.2] - 2021.9.12
- More accurate
@@ -123,6 +131,7 @@
- Initial public release
[Unreleased]: https://github.com/maurosoria/dirsearch/tree/master
+[0.4.2]: https://github.com/maurosoria/dirsearch/tree/v0.4.2
[0.4.1]: https://github.com/maurosoria/dirsearch/tree/v0.4.1
[0.4.0]: https://github.com/maurosoria/dirsearch/tree/v0.4.0
[0.3.9]: https://github.com/maurosoria/dirsearch/tree/v0.3.9
diff --git a/PKGBUILD b/PKGBUILD
index 2fcab8628dea..90c5a2750238 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _name="${pkgname%-git}"
epoch=1
pkgver() { git -C "$_name" describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'; }
-pkgver=0.4.2.r56.b83e68c
+pkgver=0.4.2.r298.ec05dec
pkgrel=1
pkgdesc='Web path scanner/fuzzer, written in Python'
@@ -22,26 +22,22 @@ depends=('python' 'python-certifi' 'python-chardet' 'python-urllib3' 'python-cry
'python-pysocks' 'python-cffi')
changelog=CHANGELOG.md
-backup=("etc/$_name/default.conf")
source=("git+$url.git")
sha256sums=('SKIP')
-prepare() {
- # refrain from trying to write logs/reports into the apps (readonly) folder
- sed -i '/report-output-folder\|logs-folder/s/^# *\([^=]*\)=.*/\1= ./' "$_name/default.conf"
-}
+prepare() { sed -i '/^charset_normalizer/s/~=/>=/' "$_name/requirements.txt"; }
package() {
cd "$_name"
PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 *.md -t"$pkgdir/usr/share/doc/$_name/"
- # fix the default.conf file location
- local py_ver="$(python -V | sed 's/Python \(3\.[0-9]\+\).*/\1/')"
- cd "$pkgdir"
- install -dm755 "etc/$_name"
- mv "usr/lib/python$py_ver/site-packages/$_name/default.conf" "etc/$_name/"
- ln -sv "/etc/$_name/default.conf" "usr/lib/python$py_ver/site-packages/$_name/"
+ ## fix the default.conf file location
+ #local py_ver="$(python -V | sed 's/Python \(3\.[0-9]\+\).*/\1/')"
+ #cd "$pkgdir"
+ #install -dm755 "etc/$_name"
+ #mv "usr/lib/python$py_ver/site-packages/$_name/default.conf" "etc/$_name/"
+ #ln -sv "/etc/$_name/default.conf" "usr/lib/python$py_ver/site-packages/$_name/"
}