summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD43
-rw-r--r--allow-zero-timeout.patch27
3 files changed, 70 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 801ac3d13751..eeeb611d9de0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = distcc-arm-avahi
pkgdesc = Distributed compilation service for C, C++ and Objective-C (with zeroconf)
- pkgver = 3.3.3
- pkgrel = 7
+ pkgver = 3.4
+ pkgrel = 1
url = https://github.com/distcc/distcc
arch = arm
arch = armv6h
@@ -10,21 +10,27 @@ pkgbase = distcc-arm-avahi
license = GPL
makedepends = git
makedepends = python
+ makedepends = gtk3
depends = avahi
depends = popt
- optdepends = python
- provides = distcc=3.3.3
+ optdepends = python: for python bindings
+ optdepends = gtk3: for distccmon
+ provides = distcc=3.4
conflicts = distcc
backup = etc/conf.d/distccd
backup = etc/distcc/hosts
- source = git+https://github.com/distcc/distcc#commit=4cde9bcfbda589abd842e3bbc652ce369085eaae
+ source = git+https://github.com/distcc/distcc?signed#tag=v3.4
source = distccd.conf.d
source = distccd.service
source = sysusers.conf
- sha256sums = SKIP
- sha256sums = 43e02b461841ca2976816c244a0eca8b24820ca143f73cc0924403d75a8c012f
- sha256sums = 360493245590d8c1480ff93cd30c9e81cb86efebacd78e45f37e7d6cdbcc2136
- sha256sums = 4e037a6225f498b51d6902d117be979454ac78ec5fd2f65f1d5a38e10859612a
+ source = meson_triple.patch::https://github.com/distcc/distcc/pull/427/commits/850db9eec0d5dd7f47ade8ffca91b679081f6d85.patch
+ source = allow-zero-timeout.patch
+ validpgpkeys = 30782E2BE4EB9FD5B293D3DA6D100BF096B8A005
+ b2sums = SKIP
+ b2sums = c48a6daea2cae5e5865c488e612c819e6f9bf4a1b205e2cd264b795de3450d40b0fe05264fbd8a3fe861f03e38d91e7e791ad67e22da5b5d0b43bcb380b8b4c9
+ b2sums = 9b6ffc02e9360fd92f7595e96ef2d69b5f6d72acf343009375fa081f86b26f51960b139c4f6e0e3c8befa37eba4894d61351bbfab6386389c262db0cc01a8b8e
+ b2sums = d1b057ce49994ac61e9d5a861c1c770452102300d47a9c396b3272d7f5afbd3fe3e865e6db11c046e73ae3b6886bc8970a10624650731d55132362436904f989
+ b2sums = 9e2fcd16070837f45852f4f8be6fc1a53d2f4c70a4058260d97ebde7d6bc58a6557d90a71b69a6a17d53e68c2b4d55b94afaf10b34610cac9ecf925298a02799
+ b2sums = 9fb83627feffba4093ea68f31cdd9257d0626f1c97aff4cd55ab74d02aceabc763e1fc59c35ddc042b61113c081b1f4cc64b8021e7ae8a5883641e7cc488f7ec
pkgname = distcc-arm-avahi
-
diff --git a/PKGBUILD b/PKGBUILD
index d37980fc138d..6ba06d422cf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,48 +5,59 @@
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
pkgname=distcc-arm-avahi
-pkgver=3.3.3
-pkgrel=7
+pkgver=3.4
+pkgrel=1
pkgdesc='Distributed compilation service for C, C++ and Objective-C (with zeroconf)'
-provides=('distcc=3.3.3')
+provides=('distcc=3.4')
conflicts=('distcc')
arch=(arm armv6h armv7h aarch64)
url='https://github.com/distcc/distcc'
license=(GPL)
depends=(avahi popt)
-makedepends=(git python)
-optdepends=(python)
+makedepends=(git python gtk3)
+optdepends=("python: for python bindings"
+ "gtk3: for distccmon")
backup=(etc/conf.d/distccd
etc/distcc/hosts)
-source=("git+$url#commit=4cde9bcfbda589abd842e3bbc652ce369085eaae" # tag: v3.3.3
+source=("git+$url?signed#tag=v$pkgver"
distccd.conf.d
distccd.service
- sysusers.conf)
-sha256sums=('SKIP'
- '43e02b461841ca2976816c244a0eca8b24820ca143f73cc0924403d75a8c012f'
- '360493245590d8c1480ff93cd30c9e81cb86efebacd78e45f37e7d6cdbcc2136'
- '4e037a6225f498b51d6902d117be979454ac78ec5fd2f65f1d5a38e10859612a')
+ sysusers.conf
+ meson_triple.patch::https://github.com/distcc/distcc/pull/427/commits/850db9eec0d5dd7f47ade8ffca91b679081f6d85.patch
+ allow-zero-timeout.patch)
+b2sums=('SKIP'
+ 'c48a6daea2cae5e5865c488e612c819e6f9bf4a1b205e2cd264b795de3450d40b0fe05264fbd8a3fe861f03e38d91e7e791ad67e22da5b5d0b43bcb380b8b4c9'
+ '9b6ffc02e9360fd92f7595e96ef2d69b5f6d72acf343009375fa081f86b26f51960b139c4f6e0e3c8befa37eba4894d61351bbfab6386389c262db0cc01a8b8e'
+ 'd1b057ce49994ac61e9d5a861c1c770452102300d47a9c396b3272d7f5afbd3fe3e865e6db11c046e73ae3b6886bc8970a10624650731d55132362436904f989'
+ '9e2fcd16070837f45852f4f8be6fc1a53d2f4c70a4058260d97ebde7d6bc58a6557d90a71b69a6a17d53e68c2b4d55b94afaf10b34610cac9ecf925298a02799'
+ '9fb83627feffba4093ea68f31cdd9257d0626f1c97aff4cd55ab74d02aceabc763e1fc59c35ddc042b61113c081b1f4cc64b8021e7ae8a5883641e7cc488f7ec')
+validpgpkeys=(30782E2BE4EB9FD5B293D3DA6D100BF096B8A005) # Shawn Landden
prepare() {
cd "$srcdir/distcc"
+ # see FS#78800
+ patch -p1 -i ../meson_triple.patch
+
+ patch -p1 -i ../allow-zero-timeout.patch
+
./autogen.sh
sed -i 's/ install-gnome-data//g' Makefile.in
-
- # FS#66418, support Python 3.9
- find . -name "*.py" -type f -exec sed -i 's/time.clock()/time.perf_counter()/g' {} \;
}
build() {
cd "$srcdir/distcc"
- export CFLAGS+=' -fcommon'
+ export CFLAGS+=' -DPY_SSIZE_T_CLEAN -fcommon'
+
./configure \
--enable-rfc2553 \
--mandir=/usr/share/man \
--prefix=/usr \
--sbindir=/usr/bin \
- --sysconfdir=/etc
+ --sysconfdir=/etc \
+ --with-gtk
+
make WERROR_CFLAGS= INCLUDESERVER_PYTHON=/usr/bin/python
}
diff --git a/allow-zero-timeout.patch b/allow-zero-timeout.patch
new file mode 100644
index 000000000000..f75d99166732
--- /dev/null
+++ b/allow-zero-timeout.patch
@@ -0,0 +1,27 @@
+diff -urN a/src/io.c b/src/io.c
+--- a/src/io.c 2011-04-05 12:58:58.000000000 -0600
++++ b/src/io.c 2014-07-07 05:44:18.668161665 -0600
+@@ -43,6 +43,7 @@
+ #include <string.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <limits.h>
+
+ #include <sys/stat.h>
+ #include <sys/types.h>
+@@ -75,11 +76,10 @@
+ const char *user_timeout = getenv("DISTCC_IO_TIMEOUT");
+ if (user_timeout) {
+ int parsed_user_timeout = atoi(user_timeout);
+- if (parsed_user_timeout <= 0) {
+- rs_log_error("Bad DISTCC_IO_TIMEOUT value: %s", user_timeout);
+- exit(EXIT_BAD_ARGUMENTS);
+- }
+- current_timeout = parsed_user_timeout;
++ if (parsed_user_timeout <= 0)
++ current_timeout = INT_MAX;
++ else
++ current_timeout = parsed_user_timeout;
+ } else {
+ current_timeout = default_dcc_io_timeout;
+ }