summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD36
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..314c22a5900b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Wed Dec 30 21:58:47 UTC 2015
+pkgbase = django-overextends
+ pkgdesc = A Django reusable app providing the ability to use circular template inheritance
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/stephenmcd/django-overextends
+ arch = any
+ license = BSD
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python-sphinx-me
+ makedepends = python-django
+ makedepends = python2
+ makedepends = python2-setuptools
+ makedepends = python2-sphinx-me
+ makedepends = python2-django
+ source = https://pypi.python.org/packages/source/d/django-overextends/django-overextends-0.4.1.tar.gz
+ md5sums = 025bde6a2b1aa3070440debfdd014779
+
+pkgname = python-django-overextends
+ depends = python
+ depends = python-sphinx-me
+ depends = python-django
+
+pkgname = python2-django-overextends
+ depends = python2
+ depends = python2-sphinx-me
+ depends = python2-django
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6148aa07fdb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgbase=django-overextends
+pkgname=('python-django-overextends' 'python2-django-overextends')
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="A Django reusable app providing the ability to use circular template inheritance"
+arch=('any')
+license=('BSD')
+url="https://github.com/stephenmcd/django-overextends"
+makedepends=('python' 'python-setuptools' 'python-sphinx-me' 'python-django'
+ 'python2' 'python2-setuptools' 'python2-sphinx-me' 'python2-django')
+source=("https://pypi.python.org/packages/source/d/django-overextends/django-overextends-${pkgver}.tar.gz")
+md5sums=('025bde6a2b1aa3070440debfdd014779')
+
+package_python-django-overextends() {
+ depends=('python' 'python-sphinx-me' 'python-django')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}" -O1
+ # We don't need the tests
+ rm -rf "${pkgdir}/usr/lib/python3.5/site-packages/test_project"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_python2-django-overextends() {
+ depends=('python2' 'python2-sphinx-me' 'python2-django')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
+ python2 setup.py install --root="${pkgdir}" -O1
+ # We don't need the tests
+ rm -rf "${pkgdir}/usr/lib/python2.7/site-packages/test_project"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}