summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c5572d052d1..d2b412d1192a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dmarc-cat
pkgdesc = Small utility to decode the report sent by various email providers following the DMARC spec
pkgver = 0.15.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/keltia/dmarc-cat
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index d88b288a69d7..696298d14e14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=dmarc-cat
pkgver=0.15.0
-pkgrel=4
+pkgrel=5
pkgdesc='Small utility to decode the report sent by various email providers following the DMARC spec'
arch=('x86_64')
url='https://github.com/keltia/dmarc-cat'
@@ -12,12 +12,19 @@ makedepends=(go)
source=("dmarc-cat-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('886bf33ba60d601de74a1e9d437a8e09eea5c03a05b09c0f685fa02d1c174bba')
+prepare(){
+ cd "$pkgname-$pkgver"
+ export GOPATH="${srcdir}"
+ go mod download
+}
+
build() {
cd "$pkgname-$pkgver"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
+ export GOPATH="${srcdir}"
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
go build \