summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD43
-rw-r--r--docbook-utils-0.6.14-grep_fix-1.patch33
-rw-r--r--html.tar.gzbin0 -> 22838 bytes
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f6563c0e6c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = docbook-utils
+ pkgdesc = Shell scripts to manage DocBook documents
+ pkgver = 0.6.14
+ pkgrel = 5
+ url = http://sources.redhat.com/docbook-tools/
+ arch = any
+ license = GPL2
+ depends = docbook-sgml31
+ depends = docbook-dsssl
+ depends = jade
+ depends = docbook-xml-dtd
+ depends = perl-sgmls
+ depends = lynx
+ depends = opensp
+ conflicts = docbook2x
+ source = html.tar.gz
+ source = ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/docbook-utils-0.6.14.tar.gz
+ source = docbook-utils-0.6.14-grep_fix-1.patch
+ sha256sums = 257789a91ec92f5db809e966aaa324c2d259298d4815d356932b1134e6a3ba14
+ sha256sums = 48faab8ee8a7605c9342fb7b906e0815e3cee84a489182af38e8f7c0df2e92e9
+ sha256sums = ddf0ddca0a540fd4f34f38b7b9090f96746e37da12b4e2bf8f4174c5ad61f54a
+
+pkgname = docbook-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..345724aa6f0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Andreas B. Wagner <AndreasBWagner@pointfree.net>
+# Contributor: Suat SARIALP <muhendis.suat@gmail.com>
+
+set -u
+pkgname='docbook-utils'
+pkgver='0.6.14'
+pkgrel='5'
+pkgdesc='Shell scripts to manage DocBook documents'
+#arch=('i686' 'x86_64')
+arch=('any')
+url='http://sources.redhat.com/docbook-tools/'
+license=('GPL2')
+depends=('docbook-sgml31' 'docbook-dsssl' 'jade' 'docbook-xml-dtd' 'perl-sgmls' 'lynx' 'opensp')
+conflicts=('docbook2x')
+source=('html.tar.gz' "ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/${pkgname}-${pkgver}.tar.gz" 'docbook-utils-0.6.14-grep_fix-1.patch')
+sha256sums=('257789a91ec92f5db809e966aaa324c2d259298d4815d356932b1134e6a3ba14'
+ '48faab8ee8a7605c9342fb7b906e0815e3cee84a489182af38e8f7c0df2e92e9'
+ 'ddf0ddca0a540fd4f34f38b7b9090f96746e37da12b4e2bf8f4174c5ad61f54a')
+
+prepare() {
+ set -u
+ cd "${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/docbook-utils-0.6.14-grep_fix-1.patch"
+ ./configure --prefix='/usr' --sysconfdir='/etc'
+ cp -p "${srcdir}/html"/* 'doc/HTML'
+ set +u
+}
+
+package() {
+ set -u
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" mandir='/usr/share/man' htmldir="/usr/share/doc/${pkgname}/html" install
+ #common alternative names
+ local doctype
+ for doctype in 'html' 'ps' 'dvi' 'man' 'pdf' 'rtf' 'tex' 'texi' 'txt'; do
+ ln -sf "docbook2${doctype}" "${pkgdir}/usr/bin/db2${doctype}"
+ done
+ set +u
+}
+set +u
+
+# vim:set ts=2 sw=2 et:
diff --git a/docbook-utils-0.6.14-grep_fix-1.patch b/docbook-utils-0.6.14-grep_fix-1.patch
new file mode 100644
index 000000000000..f9666975f0a7
--- /dev/null
+++ b/docbook-utils-0.6.14-grep_fix-1.patch
@@ -0,0 +1,33 @@
+Submitted By: Ken Moffat <ken at linuxfromscratch dot org>
+Date: 2011-01-01
+Initial Package Version: 0.6.14
+Upstream Status: unknown
+Origin: fedora
+Description: Grep-2.7 errors out on the 'space' syntax, causing
+docbook2html to fail. Fixed up by hand (the fedora version depends
+on a different patch which adds --color=never).
+
+diff -Naur docbook-utils-0.6.14.orig/bin/jw.in docbook-utils-0.6.14//bin/jw.in
+--- docbook-utils-0.6.14.orig/bin/jw.in 2003-04-30 17:21:49.000000000 +0100
++++ docbook-utils-0.6.14//bin/jw.in 2011-01-01 18:43:21.558959786 +0000
+@@ -80,9 +80,9 @@
+ SGML_CATALOGS_DIR="/etc/sgml"
+ if [ -f "$SGML_CONF" ]
+ then
+- RE='^[:space:]*SGML_BASE_DIR[:space:]*=[:space:]*'
++ RE='^[[:space:]]*SGML_BASE_DIR[[:space:]]*=[[:space:]]*'
+ SGML_BASE_DIR=`grep $RE $SGML_CONF | sed "s/$RE//"`
+- RE='^[:space:]*SGML_CATALOGS_DIR[:space:]*=[:space:]*'
++ RE='^[[:space:]]*SGML_CATALOGS_DIR[[:space:]]*=[[:space:]]*'
+ SGML_CATALOGS_DIR=`grep $RE $SGML_CONF | sed "s/$RE//"`
+ fi
+
+@@ -312,7 +312,7 @@
+ SGML_CATALOG_FILES=$SGML_CENTRALIZED_CATALOG
+ else
+ SGML_CATALOG_FILES=`find $SGML_BASE_DIR -name catalog`
+- SGML_CATALOG_FILES=`echo "$SGML_CATALOG_FILES" | tr [:space:] :`
++ SGML_CATALOG_FILES=`echo "$SGML_CATALOG_FILES" | tr [[:space:]] :`
+ fi
+ ;;
+ no) SGML_CATALOG_FILES=""
diff --git a/html.tar.gz b/html.tar.gz
new file mode 100644
index 000000000000..eb63a616ec11
--- /dev/null
+++ b/html.tar.gz
Binary files differ