summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore16
-rw-r--r--PKGBUILD56
-rw-r--r--dodo-mail.install5
4 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c29ffebd6cc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = dodo-mail-git
+ pkgdesc = A graphical, hackable email client based on notmuch
+ pkgver = r223.ed02090
+ pkgrel = 1
+ url = https://github.com/akissinger/dodo
+ install = dodo-mail.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-bleach
+ depends = python-pyqt6
+ depends = python-pyqt6-webengine
+ depends = hicolor-icon-theme
+ depends = notmuch
+ depends = w3m
+ optdepends = offlineimap: check mail and sync with a local maildir
+ optdepends = msmtp: a sendmail-compatible SMTP client to send mail
+ optdepends = python-gnupg: pgp/mime support
+ provides = dodo-mail
+ conflicts = dodo-mail
+ source = dodo-mail::git+https://github.com/akissinger/dodo
+ md5sums = SKIP
+
+pkgname = dodo-mail-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..93093ad0347c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,16 @@
+dodo-mail/
+
+# ---> ArchLinuxPackages
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c810ae2a5fd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: fossdd <fossdd@pwned.life>
+pkgname=dodo-mail-git
+_pkgname="${pkgname%-git}"
+pkgver=r223.ed02090
+pkgrel=1
+pkgdesc='A graphical, hackable email client based on notmuch'
+arch=('any')
+url="https://github.com/akissinger/dodo"
+license=('GPL3')
+groups=()
+depends=(
+ 'python'
+ 'python-bleach'
+ 'python-pyqt6'
+ 'python-pyqt6-webengine'
+ 'hicolor-icon-theme'
+ 'notmuch'
+ 'w3m'
+)
+makedepends=(
+ 'git'
+ 'python-setuptools'
+)
+optdepends=(
+ 'offlineimap: check mail and sync with a local maildir'
+ 'msmtp: a sendmail-compatible SMTP client to send mail'
+ 'python-gnupg: pgp/mime support'
+)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+replaces=()
+backup=()
+options=()
+install="$_pkgname.install"
+source=("$_pkgname::git+$url")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ # Git, tags available
+ # printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ # Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "$srcdir/$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
diff --git a/dodo-mail.install b/dodo-mail.install
new file mode 100644
index 000000000000..92be57d6b022
--- /dev/null
+++ b/dodo-mail.install
@@ -0,0 +1,5 @@
+# arg 1: the new package version
+post_install() {
+ echo 'Check with <https://github.com/akissinger/dodo#prerequisites> to install and setup all required prerequisites'
+ echo 'Also create a configuration file to ~/.config/dodo/config.py, before the first start. See here: https://github.com/akissinger/dodo#configuration'
+}