summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
-rw-r--r--dolphin-megasync.install12
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8ec316413f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dolphin-megasync
+ pkgdesc = Upload your files to your Mega account from Dolphin file manager.
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = https://mega.co.nz/#sync
+ install = dolphin-megasync.install
+ arch = i686
+ arch = x86_64
+ license = custom:The Clarified Artistic License
+ depends = megasync
+ depends = dolphin
+ source = https://mega.nz/linux/MEGAsync/xUbuntu_17.04/dolphin-megasync_3.0.1.orig.tar.gz
+ sha256sums = 050f33301972083f9d622d127ad566bc95ea33a33027b296b7668dbb9802c5ed
+
+pkgname = dolphin-megasync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..399fed2988c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: XavierCLL <xavier.corredor.llano (a) gmail.com>
+
+pkgname="dolphin-megasync"
+pkgver=3.0.1
+pkgrel=1
+pkgdesc="Upload your files to your Mega account from Dolphin file manager."
+arch=('i686' 'x86_64')
+url="https://mega.co.nz/#sync"
+license=('custom:The Clarified Artistic License')
+depends=('megasync' 'dolphin')
+source=("https://mega.nz/linux/MEGAsync/xUbuntu_17.04/${pkgname}_${pkgver}.orig.tar.gz")
+sha256sums=('050f33301972083f9d622d127ad566bc95ea33a33027b296b7668dbb9802c5ed')
+install="${pkgname}.install"
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ rm CMakeLists.txt
+ mv CMakeLists_kde5.txt CMakeLists.txt
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm 644 megasync-plugin.desktop $pkgdir/usr/share/kservices5/ServiceMenus/megasync-plugin.desktop
+ install -Dm 644 megasyncplugin.so $pkgdir/usr/lib/qt/plugins/megasyncplugin.so
+ install -Dm 644 megasyncdolphinoverlayplugin.so $pkgdir/usr/lib/qt/plugins/kf5/overlayicon/megasyncdolphinoverlayplugin.so
+
+ cd "data/emblems"
+ for size in 32x32 64x64
+ do
+ install -dm 755 ${pkgdir}/usr/share/icons/hicolor/${size}/emblems
+ install -m 644 -p ${size}/mega-dolphin-{pending,synced,syncing}.png ${pkgdir}/usr/share/icons/hicolor/${size}/emblems/
+ done
+}
+
+# vim:set ts=4 sw=2 ft=sh et:
diff --git a/dolphin-megasync.install b/dolphin-megasync.install
new file mode 100644
index 000000000000..aca18c812f13
--- /dev/null
+++ b/dolphin-megasync.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_remove() {
+ post_install $1
+}