summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD14
-rwxr-xr-xdolphin-open-wezterm.sh2
-rwxr-xr-xdolphin-wezterm.install15
4 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0a392741f8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = dolphin-wezterm
+ pkgdesc = Change the default terminal emulator for Dolphin to WezTerm
+ pkgver = 0.1.0
+ pkgrel = 1
+ install = dolphin-wezterm.install
+ arch = any
+ depends = dolphin
+ depends = wezterm
+ source = dolphin-open-wezterm.sh
+ sha256sums = 53c595fa527837bf9816f6cb9bdc5ab8aa32e36be99b25d6f42f2033b95201c1
+
+pkgname = dolphin-wezterm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..4bda7c6b5e44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,14 @@
+# Maintainer: Funami
+pkgname=dolphin-wezterm
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Change the default terminal emulator for Dolphin to WezTerm"
+arch=('any')
+depends=('dolphin' 'wezterm')
+install=dolphin-wezterm.install
+source=('dolphin-open-wezterm.sh')
+sha256sums=('53c595fa527837bf9816f6cb9bdc5ab8aa32e36be99b25d6f42f2033b95201c1')
+
+package() {
+ install -Dm755 "$srcdir/dolphin-open-wezterm.sh" -t "$pkgdir/usr/lib/dolphin-wezterm"
+}
diff --git a/dolphin-open-wezterm.sh b/dolphin-open-wezterm.sh
new file mode 100755
index 000000000000..b07220d05e6a
--- /dev/null
+++ b/dolphin-open-wezterm.sh
@@ -0,0 +1,2 @@
+#!/usr/bin/bash
+wezterm start --cwd "$(pwd)" -- "$@"
diff --git a/dolphin-wezterm.install b/dolphin-wezterm.install
new file mode 100755
index 000000000000..3ec7f4c3d226
--- /dev/null
+++ b/dolphin-wezterm.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo
+ echo 'Change the default terminal emulator for Dolphin to WezTerm by adding this to the ~/.config/kdeglobals file:'
+ echo '[General]'
+ echo 'TerminalApplication=/usr/lib/dolphin-wezterm/dolphin-open-wezterm.sh'
+ echo
+}
+
+post_remove() {
+ echo
+ echo 'Remember to remove the added section in the ~/.config/kdeglobals file:'
+ echo '[General]'
+ echo 'TerminalApplication=/usr/lib/dolphin-wezterm/dolphin-open-wezterm.sh'
+ echo
+}