summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--boost1.66.patch33
3 files changed, 10 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98922e059177..041f3caee5a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = domoticz
pkgdesc = Web based home automation
- pkgver = 3.8153
- pkgrel = 2
+ pkgver = 4.9700
+ pkgrel = 1
url = http://www.domoticz.com
install = domoticz.install
arch = i686
@@ -20,12 +20,10 @@ pkgbase = domoticz
depends = boost-libs
depends = lua
depends = mosquitto
- source = https://github.com/domoticz/domoticz/archive/3.8153.tar.gz
+ source = https://github.com/domoticz/domoticz/archive/4.9700.tar.gz
source = domoticz.service
- source = boost1.66.patch
- sha256sums = 5ea8f37f2ef900e9bd17b1b5375e75bfdec4f09001e3e2e0b647a260989d014c
+ sha256sums = c31f185a1ffac01b86a77bf33e059a4403d814e826c9d6639c63c2e9afa55a46
sha256sums = 52ea28893fc70a278a728f975c249ace48e48f595c9da01895bde115e8e6b255
- sha256sums = 04bf1daa167c00f621715578e6d6631cc059b7d7ca3741e44b2b7b316a2cf3a5
pkgname = domoticz
diff --git a/PKGBUILD b/PKGBUILD
index dfee74966e97..0532ae146bad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jameson Pugh <imntreal@gmail.com>
pkgname=domoticz
-pkgver=3.8153
-pkgrel=2
+pkgver=4.9700
+pkgrel=1
pkgdesc="Web based home automation"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="http://www.domoticz.com"
@@ -11,16 +11,12 @@ depends=('openzwave' 'libusb-compat' 'curl' 'sqlite' 'boost-libs' 'lua' 'mosquit
makedepends=('git' 'cmake' 'boost')
install='domoticz.install'
source=("https://github.com/domoticz/domoticz/archive/${pkgver}.tar.gz"
- 'domoticz.service'
- 'boost1.66.patch')
-sha256sums=('5ea8f37f2ef900e9bd17b1b5375e75bfdec4f09001e3e2e0b647a260989d014c'
- '52ea28893fc70a278a728f975c249ace48e48f595c9da01895bde115e8e6b255'
- '04bf1daa167c00f621715578e6d6631cc059b7d7ca3741e44b2b7b316a2cf3a5')
+ 'domoticz.service')
+sha256sums=('c31f185a1ffac01b86a77bf33e059a4403d814e826c9d6639c63c2e9afa55a46'
+ '52ea28893fc70a278a728f975c249ace48e48f595c9da01895bde115e8e6b255')
prepare() {
mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 -i ../boost1.66.patch
}
build() {
@@ -34,7 +30,7 @@ build() {
-DUSE_BUILTIN_ZLIB=NO \
-DUSE_STATIC_BOOST=NO \
-DUSE_STATIC_LIBSTDCXX=NO \
- -DUSE_STATIC_OPENZWAVE=NO \
+ -DUSE_OPENSSL_STATIC=NO \
..
}
diff --git a/boost1.66.patch b/boost1.66.patch
deleted file mode 100644
index 9cabf860ceb5..000000000000
--- a/boost1.66.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Naur domoticz-3.8153-orig/webserver/proxyclient.cpp domoticz-3.8153/webserver/proxyclient.cpp
---- domoticz-3.8153-orig/webserver/proxyclient.cpp 2018-01-11 16:09:55.976665686 -0500
-+++ domoticz-3.8153/webserver/proxyclient.cpp 2018-01-11 16:12:24.747525079 -0500
-@@ -639,7 +639,7 @@
- void CProxyManager::StartThread()
- {
- try {
-- boost::asio::ssl::context ctx(io_service, boost::asio::ssl::context::sslv23);
-+ boost::asio::ssl::context ctx(boost::asio::ssl::context::sslv23);
- ctx.set_verify_mode(boost::asio::ssl::verify_none);
-
- proxyclient.reset(new CProxyClient(io_service, ctx, m_pWebEm));
-diff -Naur domoticz-3.8153-orig/webserver/server.cpp domoticz-3.8153/webserver/server.cpp
---- domoticz-3.8153-orig/webserver/server.cpp 2018-01-11 16:09:55.976665686 -0500
-+++ domoticz-3.8153/webserver/server.cpp 2018-01-11 16:12:24.747525079 -0500
-@@ -148,7 +148,7 @@
- ssl_server::ssl_server(const ssl_server_settings & ssl_settings, request_handler & user_request_handler) :
- server_base(ssl_settings, user_request_handler),
- settings_(ssl_settings),
-- context_(io_service_, ssl_settings.get_ssl_method())
-+ context_(ssl_settings.get_ssl_method())
- {
- #ifdef DEBUG_WWW
- _log.Log(LOG_STATUS, "[web:%s] create ssl_server using ssl_server_settings : %s", ssl_settings.listening_port.c_str(), ssl_settings.to_string().c_str());
-@@ -161,7 +161,7 @@
- ssl_server::ssl_server(const server_settings & settings, request_handler & user_request_handler) :
- server_base(settings, user_request_handler),
- settings_(dynamic_cast<ssl_server_settings const &>(settings)),
-- context_(io_service_, dynamic_cast<ssl_server_settings const &>(settings).get_ssl_method()) {
-+ context_(dynamic_cast<ssl_server_settings const &>(settings).get_ssl_method()) {
- #ifdef DEBUG_WWW
- _log.Log(LOG_STATUS, "[web:%s] create ssl_server using server_settings : %s", settings.listening_port.c_str(), settings.to_string().c_str());
- #endif