summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87f296304f8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = done-git
+ pkgdesc = Done is a simple to do app that aims to improve on the existing set of features provided to do apps to deliver the ultimate experience.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/edfloreshz/done
+ arch = x86_64
+ license = GPL2
+ makedepends = cargo
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ depends = gtk4
+ depends = libadwaita
+ depends = pkg-config
+ provides = done
+ conflicts = done
+ source = done-git::git+https://github.com/edfloreshz/done#branch=main
+ md5sums = SKIP
+
+pkgname = done-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd523908026d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Eduardo Flores <edfloreshz@gmail.com>
+
+pkgname=done-git
+pkgrel=1
+pkgver=0.1.0
+pkgdesc="Done is a simple to do app that aims to improve on the existing set of features provided to do apps to deliver the ultimate experience."
+arch=('x86_64')
+url="https://github.com/edfloreshz/done"
+license=('GPL2')
+depends=('gtk4' 'libadwaita' 'pkg-config')
+makedepends=('cargo' 'git' 'meson' 'ninja')
+optdepends=()
+provides=('done')
+conflicts=('done')
+source=("done-git::git+https://github.com/edfloreshz/done#branch=main")
+md5sums=('SKIP')
+
+prepare() {
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ meson --prefix=/usr --buildtype=plain $pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}