summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD28
-rw-r--r--dontmove.desktop10
-rw-r--r--dontmove.sh4
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae117aa5fb7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = dontmove-hib
+ pkgdesc = Ninjas, failure, ludonarrative dissonance and player investment manipulation
+ pkgver = 1.3
+ pkgrel = 2
+ url = http://www.steverichey.com/portfolio/dont-move/
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ source = dontmove.sh
+ source = dontmove.desktop
+ source = dontmove.png::http://media.slidedb.com/images/games/1/25/24384/am_Official_HD_Icon_Faded_512.png
+ md5sums = c649e1c3160c6c452d39ad1ca05deb48
+ md5sums = a598147fb87e07dc86db2b3394666f03
+ md5sums = 204247c9c25b68b3c50bcfb68e16e93b
+ source_i686 = hib://DontMove_v1-3_Linux-32.tar
+ md5sums_i686 = 5e5aee1e2ca9a4b9bd15a47981982867
+ source_x86_64 = hib://DontMove_v1-3_Linux-64.tar
+ depends_x86_64 = lib32-glibc
+ depends_x86_64 = lib32-gcc-libs
+ md5sums_x86_64 = ae78a7b9c5c4442733ee87f64855b495
+
+pkgname = dontmove-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63d53b59ddce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+pkgname=dontmove-hib
+pkgver=1.3
+pkgrel=2
+pkgdesc='Ninjas, failure, ludonarrative dissonance and player investment manipulation'
+arch=('i686' 'x86_64')
+url='http://www.steverichey.com/portfolio/dont-move/'
+license=(custom:commercial)
+depends_x86_64=('lib32-glibc' 'lib32-gcc-libs')
+source=('dontmove.sh' 'dontmove.desktop'
+ 'dontmove.png::http://media.slidedb.com/images/games/1/25/24384/am_Official_HD_Icon_Faded_512.png')
+source_i686=('hib://DontMove_v1-3_Linux-32.tar')
+source_x86_64=('hib://DontMove_v1-3_Linux-64.tar')
+md5sums=('c649e1c3160c6c452d39ad1ca05deb48'
+ 'a598147fb87e07dc86db2b3394666f03'
+ '204247c9c25b68b3c50bcfb68e16e93b')
+md5sums_i686=('5e5aee1e2ca9a4b9bd15a47981982867')
+md5sums_x86_64=('ae78a7b9c5c4442733ee87f64855b495')
+
+package () {
+ cd "${srcdir}"
+ install -d "${pkgdir}/opt/dontmove"
+ install -m755 -t "${pkgdir}/opt/dontmove/" DontMove lime.ndll manifest regexp.dso std.dso zlib.dso
+
+ install -Dm755 dontmove.sh "${pkgdir}/usr/bin/dontmove"
+ install -Dm644 dontmove.desktop "${pkgdir}/usr/share/applications/dontmove.desktop"
+ install -Dm644 dontmove.png "${pkgdir}/usr/share/pixmaps/dontmove.png"
+}
diff --git a/dontmove.desktop b/dontmove.desktop
new file mode 100644
index 000000000000..8aa53b30d11a
--- /dev/null
+++ b/dontmove.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Don't Move
+Comment=Ninjas, failure, ludonarrative dissonance and player investment manipulation
+Exec=dontmove
+Icon=dontmove
+Terminal=false
+StartupNotify=false
+Categories=Game
diff --git a/dontmove.sh b/dontmove.sh
new file mode 100644
index 000000000000..6ce83e5595b1
--- /dev/null
+++ b/dontmove.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+(pushd /opt/dontmove
+./DontMove "$@")
+