summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--ChangeLog10
-rwxr-xr-xPKGBUILD49
-rw-r--r--donttakeitpersonally.desktop9
-rw-r--r--donttakeitpersonally.icobin0 -> 63332 bytes
-rw-r--r--donttakeitpersonally.sh2
-rw-r--r--python2.patch9
7 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e5b4ade6926
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = donttakeitpersonally
+ pkgdesc = 'don't take it personally, babe, it just ain't your story' is a visual novel game that tells a story of a new high school literature teacher, set in a prestigious private high school, and on the social networks of 2027.
+ pkgver = 1.1
+ pkgrel = 3
+ url = http://scoutshonour.com/donttakeitpersonallybabeitjustaintyourstory/
+ changelog = ChangeLog
+ arch = any
+ license = CCPL:by-nc-sa
+ depends = renpy
+ source = http://scoutshonour.com/donttakeitpersonallybabeitjustaintyourstory/don't%20take%20it%20personally,%20babe-1.1-linux-x86.tar.bz2
+ source = donttakeitpersonally.sh
+ source = donttakeitpersonally.desktop
+ source = donttakeitpersonally.ico
+ source = python2.patch
+ md5sums = ffd57c51b7bfbc28170f0a4044b1cff1
+ md5sums = 6d2a8b1da2b23cc60722814a85afabe4
+ md5sums = 08d0bb8fe6f3082eb7248b08f0d13e59
+ md5sums = 25a48bd6b230d4d92c24fd34c9a8b43f
+ md5sums = ecf6ab36828622e108d87ce931a54677
+
+pkgname = donttakeitpersonally
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..bc0adb3cb1b9
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,10 @@
+2012-16-03 AlexanderR <alexanderr at gmx dot com>
+
+ * 1.1-2 :
+ changed dep from python-renpy to renpy. added ChangeLog.
+ removed direct usage of RENPY_BASE from launcher script.
+
+2012-24-02 AlexanderR <alexanderr at gmx dot com>
+
+ * 1.1-1 :
+ uploaded version 1.1. added icon, launcher script and .desktop file.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..01d79b770ae3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: AlexanderR <rvacheva at nxt dot ru>
+
+pkgname=donttakeitpersonally
+pkgver=1.1
+pkgrel=3
+pkgdesc="'don't take it personally, babe, it just ain't your story' is a visual novel game that tells a story of a new high school literature teacher, set in a prestigious private high school, and on the social networks of 2027."
+arch=('any')
+url='http://scoutshonour.com/donttakeitpersonallybabeitjustaintyourstory/'
+license=('CCPL:by-nc-sa')
+depends=('renpy')
+changelog=ChangeLog
+source=("http://scoutshonour.com/donttakeitpersonallybabeitjustaintyourstory/don't%20take%20it%20personally,%20babe-$pkgver-linux-x86.tar.bz2"
+ "${pkgname}.sh"
+ "${pkgname}.desktop"
+ "${pkgname}.ico"
+ 'python2.patch')
+
+build() {
+ cd "$srcdir/don't take it personally, babe-$pkgver-linux-x86"
+
+ patch -p1 -i ../python2.patch
+}
+
+package() {
+ cd "$srcdir/don't take it personally, babe-$pkgver-linux-x86"
+
+ # copy main files
+ install -dm755 "$pkgdir/usr/share/$pkgname"
+ cp -r game/* "$pkgdir/usr/share/$pkgname"
+ install -m644 "don't take it personally, babe.py" "$pkgdir/usr/share/$pkgname"
+
+ # copy game readme
+ install -D -m644 'README.html' "$pkgdir/usr/share/doc/$pkgname/README.html"
+
+ # copy bash script
+ install -D -m755 "$srcdir/${pkgname}.sh" "$pkgdir/usr/bin/$pkgname"
+
+ # install desktop entry file
+ install -D -m644 "$srcdir/${pkgname}.desktop" "$pkgdir/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "$srcdir/${pkgname}.ico" "$pkgdir/usr/share/pixmaps/${pkgname}.ico"
+}
+
+md5sums=('ffd57c51b7bfbc28170f0a4044b1cff1'
+ '6d2a8b1da2b23cc60722814a85afabe4'
+ '08d0bb8fe6f3082eb7248b08f0d13e59'
+ '25a48bd6b230d4d92c24fd34c9a8b43f'
+ 'ecf6ab36828622e108d87ce931a54677')
+
+# vim:set ts=2 sw=2 et:
diff --git a/donttakeitpersonally.desktop b/donttakeitpersonally.desktop
new file mode 100644
index 000000000000..eb39d380e99c
--- /dev/null
+++ b/donttakeitpersonally.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.1
+Name=don't take it personally, babe..
+Comment=Visual novel game that tells a story of a new high school literature teacher, set in a prestigious private high school, and on the social networks of 2027
+Icon=donttakeitpersonally.ico
+Exec=/usr/bin/donttakeitpersonally
+Terminal=false
+Categories=Application;Game;
diff --git a/donttakeitpersonally.ico b/donttakeitpersonally.ico
new file mode 100644
index 000000000000..953cdd76b6d4
--- /dev/null
+++ b/donttakeitpersonally.ico
Binary files differ
diff --git a/donttakeitpersonally.sh b/donttakeitpersonally.sh
new file mode 100644
index 000000000000..e9321d42c02b
--- /dev/null
+++ b/donttakeitpersonally.sh
@@ -0,0 +1,2 @@
+#!/usr/bin/env sh
+exec env RENPY_BASE=${RENPY_BASE:-/usr/share/renpy/} python2 -OO "/usr/share/donttakeitpersonally/don't take it personally, babe.py" /usr/share/donttakeitpersonally "$@"
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..c4f3caed625e
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,9 @@
+diff -aur don't take it personally, babe-1.1-linux-x86.pristine/don't take it personally, babe.py don't take it personally, babe-1.1-linux-x86.new/don't take it personally, babe.py
+--- don't take it personally, babe-1.1-linux-x86.pristine/don't take it personally, babe.py 2012-02-25 00:27:09.243745047 +1100
++++ don't take it personally, babe-1.1-linux-x86.new/don't take it personally, babe.py 2012-02-25 00:33:04.512572777 +1100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ # Copyright 2004-2011 Tom Rothamel <pytom@bishoujo.us>
+ #